aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2015-07-15 09:42:46 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2015-07-15 09:42:46 +0000
commitce081e2ba245347b31a5731b5cfdf583cd8b0959 (patch)
tree55fc746077c0be188fb7d882a9645cfb48c38427 /os/hal/ports/STM32
parent302e691017f3a74c46ea52c22254d18f58b6435b (diff)
downloadChibiOS-ce081e2ba245347b31a5731b5cfdf583cd8b0959.tar.gz
ChibiOS-ce081e2ba245347b31a5731b5cfdf583cd8b0959.tar.bz2
ChibiOS-ce081e2ba245347b31a5731b5cfdf583cd8b0959.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@8100 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32')
-rw-r--r--os/hal/ports/STM32/STM32L0xx/platform.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/os/hal/ports/STM32/STM32L0xx/platform.mk b/os/hal/ports/STM32/STM32L0xx/platform.mk
index 0e24b00e9..2f99f0e01 100644
--- a/os/hal/ports/STM32/STM32L0xx/platform.mk
+++ b/os/hal/ports/STM32/STM32L0xx/platform.mk
@@ -3,10 +3,10 @@ ifeq ($(USE_SMART_BUILD),yes)
HALCONF := $(strip $(shell cat halconf.h | egrep -e "define"))
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
- $(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/stm32_dma.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/hal_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/st_lld.c
ifneq ($(findstring HAL_USE_ADC TRUE,$(HALCONF)),)
+ $(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/stm32_dma.c \
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/adc_lld.c
endif
ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)