aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32L4xx/platform.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-08-31 10:14:21 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-08-31 10:14:21 +0000
commit7666194a74d9f3549925d4ab420c8a3553a901b0 (patch)
treedc65755a68e6b4f1a7d3bf70aec2cd9204f0f5c7 /os/hal/ports/STM32/STM32L4xx/platform.mk
parent92fe1a35249b1723419405dc2939d19ea940d9db (diff)
downloadChibiOS-7666194a74d9f3549925d4ab420c8a3553a901b0.tar.gz
ChibiOS-7666194a74d9f3549925d4ab420c8a3553a901b0.tar.bz2
ChibiOS-7666194a74d9f3549925d4ab420c8a3553a901b0.zip
Common ISR handler prototype for STM32L4xx.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10508 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/STM32L4xx/platform.mk')
-rw-r--r--os/hal/ports/STM32/STM32L4xx/platform.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/os/hal/ports/STM32/STM32L4xx/platform.mk b/os/hal/ports/STM32/STM32L4xx/platform.mk
index 32733f96b..9134ce1a9 100644
--- a/os/hal/ports/STM32/STM32L4xx/platform.mk
+++ b/os/hal/ports/STM32/STM32L4xx/platform.mk
@@ -1,5 +1,6 @@
# Required platform files.
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32L4xx/stm32_isr.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32L4xx/hal_lld.c
# Required include directories.
@@ -16,11 +17,7 @@ endif
HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
-ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L4xx/hal_ext_lld_isr.c
-endif
else
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L4xx/hal_ext_lld_isr.c
endif
# Drivers compatible with the platform.