aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32L1xx
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2016-04-02 08:54:40 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2016-04-02 08:54:40 +0000
commit6443cb37d899f517ab165e56b450bb137e5e7ee1 (patch)
treec601db08cef45a31c6ed37951f3d006001af344b /os/hal/ports/STM32/STM32L1xx
parenta535c19183a8160054206725e958ef1ba708ac7d (diff)
downloadChibiOS-6443cb37d899f517ab165e56b450bb137e5e7ee1.tar.gz
ChibiOS-6443cb37d899f517ab165e56b450bb137e5e7ee1.tar.bz2
ChibiOS-6443cb37d899f517ab165e56b450bb137e5e7ee1.zip
Finished STM32 renaming.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@9210 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/STM32L1xx')
-rw-r--r--os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c (renamed from os/hal/ports/STM32/STM32L1xx/adc_lld.c)0
-rw-r--r--os/hal/ports/STM32/STM32L1xx/hal_adc_lld.h (renamed from os/hal/ports/STM32/STM32L1xx/adc_lld.h)0
-rw-r--r--os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.c (renamed from os/hal/ports/STM32/STM32L1xx/ext_lld_isr.c)2
-rw-r--r--os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.h (renamed from os/hal/ports/STM32/STM32L1xx/ext_lld_isr.h)0
-rw-r--r--os/hal/ports/STM32/STM32L1xx/platform.mk64
5 files changed, 33 insertions, 33 deletions
diff --git a/os/hal/ports/STM32/STM32L1xx/adc_lld.c b/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c
index 34d84632d..34d84632d 100644
--- a/os/hal/ports/STM32/STM32L1xx/adc_lld.c
+++ b/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c
diff --git a/os/hal/ports/STM32/STM32L1xx/adc_lld.h b/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.h
index 551275994..551275994 100644
--- a/os/hal/ports/STM32/STM32L1xx/adc_lld.h
+++ b/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.h
diff --git a/os/hal/ports/STM32/STM32L1xx/ext_lld_isr.c b/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.c
index e49f304b2..9287461e2 100644
--- a/os/hal/ports/STM32/STM32L1xx/ext_lld_isr.c
+++ b/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.c
@@ -26,7 +26,7 @@
#if HAL_USE_EXT || defined(__DOXYGEN__)
-#include "ext_lld_isr.h"
+#include "hal_ext_lld_isr.h"
/*===========================================================================*/
/* Driver local definitions. */
diff --git a/os/hal/ports/STM32/STM32L1xx/ext_lld_isr.h b/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.h
index 9ee76fe1e..9ee76fe1e 100644
--- a/os/hal/ports/STM32/STM32L1xx/ext_lld_isr.h
+++ b/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.h
diff --git a/os/hal/ports/STM32/STM32L1xx/platform.mk b/os/hal/ports/STM32/STM32L1xx/platform.mk
index 4ed3c8da1..e4486c731 100644
--- a/os/hal/ports/STM32/STM32L1xx/platform.mk
+++ b/os/hal/ports/STM32/STM32L1xx/platform.mk
@@ -5,70 +5,70 @@ HALCONF := $(strip $(shell cat halconf.h | egrep -e "define"))
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/DMAv1/stm32_dma.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/st_lld.c
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_st_lld.c
ifneq ($(findstring HAL_USE_ADC TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/adc_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c
endif
ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/EXTIv1/ext_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/ext_lld_isr.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/EXTIv1/hal_ext_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.c
endif
ifneq ($(findstring HAL_USE_DAC TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/DACv1/dac_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/DACv1/hal_dac_lld.c
endif
ifneq ($(findstring HAL_USE_PAL TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/GPIOv2/pal_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/GPIOv2/hal_pal_lld.c
endif
ifneq ($(findstring HAL_USE_I2C TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/I2Cv1/i2c_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/I2Cv1/hal_i2c_lld.c
endif
ifneq ($(findstring HAL_USE_RTC TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/RTCv2/rtc_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/RTCv2/hal_rtc_lld.c
endif
ifneq ($(findstring HAL_USE_SPI TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv1/spi_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv1/hal_spi_lld.c
endif
ifneq ($(findstring HAL_USE_GPT TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/gpt_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_gpt_lld.c
endif
ifneq ($(findstring HAL_USE_ICU TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/icu_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_icu_lld.c
endif
ifneq ($(findstring HAL_USE_PWM TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/pwm_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.c
endif
ifneq ($(findstring HAL_USE_SERIAL TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/serial_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/hal_serial_lld.c
endif
ifneq ($(findstring HAL_USE_UART TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/hal_uart_lld.c
endif
ifneq ($(findstring HAL_USE_USB TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USBv1/usb_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USBv1/hal_usb_lld.c
endif
ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/wdg_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/hal_wdg_lld.c
endif
else
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/adc_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/ext_lld_isr.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/EXTIv1/ext_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/DACv1/dac_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/EXTIv1/hal_ext_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/DACv1/hal_dac_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/DMAv1/stm32_dma.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/GPIOv2/pal_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/I2Cv1/i2c_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv1/spi_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/gpt_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/icu_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/RTCv2/rtc_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/pwm_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/st_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/serial_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/USBv1/usb_lld.c \
- $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/wdg_lld.c
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/GPIOv2/hal_pal_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/I2Cv1/hal_i2c_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv1/hal_spi_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_gpt_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_icu_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/RTCv2/hal_rtc_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_pwm_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/hal_st_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/hal_serial_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/hal_uart_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/USBv1/hal_usb_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/xWDGv1/hal_wdg_lld.c
endif
# Required include directories