aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32L1xx/platform.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-09-02 09:00:49 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-09-02 09:00:49 +0000
commit4c39135c94232e76011da8a055dd3eddd0031da2 (patch)
treeee76d10993619a10aa18a413f264c67ac935b1ba /os/hal/ports/STM32/STM32L1xx/platform.mk
parent0701f98135282457b20aef073b00e1f0cdda0c92 (diff)
downloadChibiOS-4c39135c94232e76011da8a055dd3eddd0031da2.tar.gz
ChibiOS-4c39135c94232e76011da8a055dd3eddd0031da2.tar.bz2
ChibiOS-4c39135c94232e76011da8a055dd3eddd0031da2.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10525 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/STM32L1xx/platform.mk')
-rw-r--r--os/hal/ports/STM32/STM32L1xx/platform.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/os/hal/ports/STM32/STM32L1xx/platform.mk b/os/hal/ports/STM32/STM32L1xx/platform.mk
index 23c6bbaae..981b1dbbb 100644
--- a/os/hal/ports/STM32/STM32L1xx/platform.mk
+++ b/os/hal/ports/STM32/STM32L1xx/platform.mk
@@ -1,5 +1,6 @@
# Required platform files.
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/stm32_isr.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_lld.c
# Required include directories.
@@ -16,15 +17,11 @@ endif
HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
-ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.c
-endif
ifneq ($(findstring HAL_USE_ADC TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c
endif
else
- $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_ext_lld_isr.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L1xx/hal_adc_lld.c
endif
# Drivers compatible with the platform.