aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32L0xx
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-09-02 09:00:49 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-09-02 09:00:49 +0000
commit4c39135c94232e76011da8a055dd3eddd0031da2 (patch)
treeee76d10993619a10aa18a413f264c67ac935b1ba /os/hal/ports/STM32/STM32L0xx
parent0701f98135282457b20aef073b00e1f0cdda0c92 (diff)
downloadChibiOS-4c39135c94232e76011da8a055dd3eddd0031da2.tar.gz
ChibiOS-4c39135c94232e76011da8a055dd3eddd0031da2.tar.bz2
ChibiOS-4c39135c94232e76011da8a055dd3eddd0031da2.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10525 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/STM32L0xx')
-rw-r--r--os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.c283
-rw-r--r--os/hal/ports/STM32/STM32L0xx/hal_lld.c4
-rw-r--r--os/hal/ports/STM32/STM32L0xx/hal_lld.h1
-rw-r--r--os/hal/ports/STM32/STM32L0xx/platform.mk5
-rw-r--r--os/hal/ports/STM32/STM32L0xx/stm32_isr.c164
-rw-r--r--os/hal/ports/STM32/STM32L0xx/stm32_isr.h (renamed from os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.h)44
6 files changed, 190 insertions, 311 deletions
diff --git a/os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.c b/os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.c
deleted file mode 100644
index 8bea63dcb..000000000
--- a/os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.c
+++ /dev/null
@@ -1,283 +0,0 @@
-/*
- ChibiOS - Copyright (C) 2006..2016 Giovanni Di Sirio
-
- Licensed under the Apache License, Version 2.0 (the "License");
- you may not use this file except in compliance with the License.
- You may obtain a copy of the License at
-
- http://www.apache.org/licenses/LICENSE-2.0
-
- Unless required by applicable law or agreed to in writing, software
- distributed under the License is distributed on an "AS IS" BASIS,
- WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
- See the License for the specific language governing permissions and
- limitations under the License.
-*/
-
-/**
- * @file STM32L0xx/hal_ext_lld_isr.c
- * @brief STM32L0xx EXT subsystem low level driver ISR code.
- *
- * @addtogroup EXT
- * @{
- */
-
-#include "hal.h"
-
-#if HAL_USE_EXT || defined(__DOXYGEN__)
-
-#include "hal_ext_lld_isr.h"
-
-/*===========================================================================*/
-/* Driver local definitions. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver exported variables. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver local variables. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver local functions. */
-/*===========================================================================*/
-
-/*===========================================================================*/
-/* Driver interrupt handlers. */
-/*===========================================================================*/
-
-#if !defined(STM32_DISABLE_EXTI01_HANDLER)
-/**
- * @brief EXTI[0]...EXTI[1] interrupt handler.
- *
- * @isr
- */
-OSAL_IRQ_HANDLER(STM32_EXTI_LINE01_HANDLER) {
- uint32_t pr;
-
- OSAL_IRQ_PROLOGUE();
-
- pr = EXTI->PR;
- pr &= EXTI->IMR & ((1U << 0) | (1U << 1));
- EXTI->PR = pr;
- if (pr & (1U << 0))
- EXTD1.config->channels[0].cb(&EXTD1, 0);
- if (pr & (1U << 1))
- EXTD1.config->channels[1].cb(&EXTD1, 1);
-
- OSAL_IRQ_EPILOGUE();
-}
-#endif
-
-#if !defined(STM32_DISABLE_EXTI23_HANDLER)
-/**
- * @brief EXTI[2]...EXTI[3] interrupt handler.
- *
- * @isr
- */
-OSAL_IRQ_HANDLER(STM32_EXTI_LINE23_HANDLER) {
- uint32_t pr;
-
- OSAL_IRQ_PROLOGUE();
-
- pr = EXTI->PR;
- pr &= EXTI->IMR & ((1U << 2) | (1U << 3));
- EXTI->PR = pr;
- if (pr & (1U << 2))
- EXTD1.config->channels[2].cb(&EXTD1, 2);
- if (pr & (1U << 3))
- EXTD1.config->channels[3].cb(&EXTD1, 3);
-
- OSAL_IRQ_EPILOGUE();
-}
-#endif
-
-#if !defined(STM32_DISABLE_EXTI4_15_HANDLER)
-/**
- * @brief EXTI[4]...EXTI[15] interrupt handler.
- *
- * @isr
- */
-OSAL_IRQ_HANDLER(STM32_EXTI_LINE4_15_HANDLER) {
- uint32_t pr;
-
- OSAL_IRQ_PROLOGUE();
-
- pr = EXTI->PR;
- pr &= EXTI->IMR & ((1U << 4) | (1U << 5) | (1U << 6) | (1U << 7) |
- (1U << 8) | (1U << 9) | (1U << 10) | (1U << 11) |
- (1U << 12) | (1U << 13) | (1U << 14) | (1U << 15));
- EXTI->PR = pr;
- if (pr & (1U << 4))
- EXTD1.config->channels[4].cb(&EXTD1, 4);
- if (pr & (1U << 5))
- EXTD1.config->channels[5].cb(&EXTD1, 5);
- if (pr & (1U << 6))
- EXTD1.config->channels[6].cb(&EXTD1, 6);
- if (pr & (1U << 7))
- EXTD1.config->channels[7].cb(&EXTD1, 7);
- if (pr & (1U << 8))
- EXTD1.config->channels[8].cb(&EXTD1, 8);
- if (pr & (1U << 9))
- EXTD1.config->channels[9].cb(&EXTD1, 9);
- if (pr & (1U << 10))
- EXTD1.config->channels[10].cb(&EXTD1, 10);
- if (pr & (1U << 11))
- EXTD1.config->channels[11].cb(&EXTD1, 11);
- if (pr & (1U << 12))
- EXTD1.config->channels[12].cb(&EXTD1, 12);
- if (pr & (1U << 13))
- EXTD1.config->channels[13].cb(&EXTD1, 13);
- if (pr & (1U << 14))
- EXTD1.config->channels[14].cb(&EXTD1, 14);
- if (pr & (1U << 15))
- EXTD1.config->channels[15].cb(&EXTD1, 15);
-
- OSAL_IRQ_EPILOGUE();
-}
-#endif
-
-#if !defined(STM32_DISABLE_EXTI16_HANDLER)
-/**
- * @brief EXTI[16] interrupt handler (PVD).
- *
- * @isr
- */
-OSAL_IRQ_HANDLER(STM32_EXTI_LINE16_HANDLER) {
- uint32_t pr;
-
- OSAL_IRQ_PROLOGUE();
-
- pr = EXTI->PR;
- pr &= EXTI->IMR & (1U << 16);
- EXTI->PR = pr;
- if (pr & (1U << 16))
- EXTD1.config->channels[16].cb(&EXTD1, 16);
-
- OSAL_IRQ_EPILOGUE();
-}
-#endif
-
-#if !defined(STM32_DISABLE_EXTI171920_HANDLER)
-/**
- * @brief EXTI[17],EXTI[19],EXTI[20] interrupt handler (RTC, CSS).
- *
- * @isr
- */
-OSAL_IRQ_HANDLER(STM32_EXTI_LINE171920_HANDLER) {
- uint32_t pr;
-
- OSAL_IRQ_PROLOGUE();
-
- pr = EXTI->PR;
- pr &= EXTI->IMR & ((1U << 17) | (1U << 19) | (1U << 20));
- EXTI->PR = pr;
- if (pr & (1U << 17))
- EXTD1.config->channels[17].cb(&EXTD1, 17);
- if (pr & (1U << 19))
- EXTD1.config->channels[19].cb(&EXTD1, 19);
- if (pr & (1U << 20))
- EXTD1.config->channels[20].cb(&EXTD1, 20);
-
- OSAL_IRQ_EPILOGUE();
-}
-#endif
-#endif /* HAL_USE_EXT */
-
-#if (HAL_USE_EXT || HAL_USE_ADC) || defined(__DOXYGEN__)
-#if !defined(STM32_DISABLE_EXTI2122_HANDLER)
-/**
- * @brief EXTI[21],EXTI[22] interrupt handler (ADC, COMP).
- * @note This handler is shared with the ADC so it is handled
- * a bit differently.
- *
- * @isr
- */
-OSAL_IRQ_HANDLER(STM32_EXTI_LINE2122_HANDLER) {
-
- OSAL_IRQ_PROLOGUE();
-
-#if HAL_USE_EXT
- {
- uint32_t pr;
-
- pr = EXTI->PR;
- pr &= EXTI->IMR & ((1U << 21) | (1U << 22));
- EXTI->PR = pr;
- if (pr & (1U << 21))
- EXTD1.config->channels[21].cb(&EXTD1, 21);
- if (pr & (1U << 22))
- EXTD1.config->channels[21].cb(&EXTD1, 22);
- }
-#endif
-#if HAL_USE_ADC
- adc_lld_serve_interrupt(&ADCD1);
-#endif
-
- OSAL_IRQ_EPILOGUE();
-}
-#endif
-#endif /* HAL_USE_EXT || HAL_USE_ADC */
-
-#if HAL_USE_EXT || defined(__DOXYGEN__)
-
-/*===========================================================================*/
-/* Driver exported functions. */
-/*===========================================================================*/
-
-/**
- * @brief Enables EXTI IRQ sources.
- *
- * @notapi
- */
-void ext_lld_exti_irq_enable(void) {
-
- nvicEnableVector(STM32_EXTI_LINE01_NUMBER,
- STM32_EXT_EXTI0_1_IRQ_PRIORITY);
- nvicEnableVector(STM32_EXTI_LINE23_NUMBER,
- STM32_EXT_EXTI2_3_IRQ_PRIORITY);
- nvicEnableVector(STM32_EXTI_LINE4_15_NUMBER,
- STM32_EXT_EXTI4_15_IRQ_PRIORITY);
- nvicEnableVector(STM32_EXTI_LINE16_NUMBER,
- STM32_EXT_EXTI16_IRQ_PRIORITY);
- nvicEnableVector(STM32_EXTI_LINE171920_NUMBER,
- STM32_EXT_EXTI17_20_IRQ_PRIORITY);
-#if HAL_USE_ADC
- /* If the ADC is not working then the vector can be enabled.*/
- if (ADCD1.state == ADC_STOP) {
- nvicEnableVector(STM32_EXTI_LINE2122_NUMBER,
- STM32_EXT_EXTI21_22_IRQ_PRIORITY);
- }
-#else
- nvicEnableVector(STM32_EXTI_LINE2122_NUMBER,
- STM32_EXT_EXTI21_22_IRQ_PRIORITY);
-#endif
-}
-
-/**
- * @brief Disables EXTI IRQ sources.
- *
- * @notapi
- */
-void ext_lld_exti_irq_disable(void) {
-
- nvicDisableVector(STM32_EXTI_LINE01_NUMBER);
- nvicDisableVector(STM32_EXTI_LINE23_NUMBER);
- nvicDisableVector(STM32_EXTI_LINE4_15_NUMBER);
- nvicDisableVector(STM32_EXTI_LINE16_NUMBER);
- nvicDisableVector(STM32_EXTI_LINE2122_NUMBER);
-#if HAL_USE_ADC
- /* If the ADC is not working then the vector can be disabled.*/
- if (ADCD1.state == ADC_STOP) {
- nvicDisableVector(STM32_EXTI_LINE171920_NUMBER);
- }
-#else
- nvicDisableVector(STM32_EXTI_LINE171920_NUMBER);
-#endif
-}
-
-#endif /* HAL_USE_EXT */
-
-/** @} */
diff --git a/os/hal/ports/STM32/STM32L0xx/hal_lld.c b/os/hal/ports/STM32/STM32L0xx/hal_lld.c
index a3577d5c9..a0766c9a0 100644
--- a/os/hal/ports/STM32/STM32L0xx/hal_lld.c
+++ b/os/hal/ports/STM32/STM32L0xx/hal_lld.c
@@ -161,10 +161,14 @@ void hal_lld_init(void) {
/* Initializes the backup domain.*/
hal_lld_backup_domain_init();
+ /* DMA subsystems initialization.*/
#if defined(STM32_DMA_REQUIRED)
dmaInit();
#endif
+ /* IRQ subsystem initialization.*/
+ irqInit();
+
/* Programmable voltage detector enable.*/
#if STM32_PVD_ENABLE
PWR->CR |= PWR_CR_PVDE | (STM32_PLS & STM32_PLS_MASK);
diff --git a/os/hal/ports/STM32/STM32L0xx/hal_lld.h b/os/hal/ports/STM32/STM32L0xx/hal_lld.h
index 94d28c565..46b104218 100644
--- a/os/hal/ports/STM32/STM32L0xx/hal_lld.h
+++ b/os/hal/ports/STM32/STM32L0xx/hal_lld.h
@@ -1188,6 +1188,7 @@
/* Various helpers.*/
#include "nvic.h"
+#include "stm32_isr.h"
#include "stm32_dma.h"
#include "stm32_rcc.h"
diff --git a/os/hal/ports/STM32/STM32L0xx/platform.mk b/os/hal/ports/STM32/STM32L0xx/platform.mk
index 3cbacdd85..1f516efc7 100644
--- a/os/hal/ports/STM32/STM32L0xx/platform.mk
+++ b/os/hal/ports/STM32/STM32L0xx/platform.mk
@@ -1,5 +1,6 @@
# Required platform files.
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/stm32_isr.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/hal_lld.c
# Required include directories.
@@ -16,11 +17,7 @@ endif
HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
-ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.c
-endif
else
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.c
endif
# Drivers compatible with the platform.
diff --git a/os/hal/ports/STM32/STM32L0xx/stm32_isr.c b/os/hal/ports/STM32/STM32L0xx/stm32_isr.c
new file mode 100644
index 000000000..04c73d850
--- /dev/null
+++ b/os/hal/ports/STM32/STM32L0xx/stm32_isr.c
@@ -0,0 +1,164 @@
+/*
+ ChibiOS - Copyright (C) 2006..2016 Giovanni Di Sirio
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/**
+ * @file STM32L0xx/stm32_isr.h
+ * @brief STM32L0xx ISR handler code.
+ *
+ * @addtogroup SRM32L0xx_ISR
+ * @{
+ */
+
+#include "hal.h"
+
+/*===========================================================================*/
+/* Driver local definitions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver exported variables. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver local variables. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver local functions. */
+/*===========================================================================*/
+
+#define exti_serve_irq(pr, channel) { \
+ \
+ if ((pr) & (1U << (channel))) { \
+ _pal_isr_code(channel); \
+ } \
+}
+
+/*===========================================================================*/
+/* Driver interrupt handlers. */
+/*===========================================================================*/
+
+#if HAL_USE_PAL || defined(__DOXYGEN__)
+/**
+ * @brief EXTI[0]...EXTI[1] interrupt handler.
+ *
+ * @isr
+ */
+OSAL_IRQ_HANDLER(Vector54) {
+ uint32_t pr;
+
+ OSAL_IRQ_PROLOGUE();
+
+ pr = EXTI->PR;
+ pr &= ((1U << 0) | (1U << 1));
+ EXTI->PR = pr;
+
+ exti_serve_irq(pr, 0);
+ exti_serve_irq(pr, 1);
+
+ OSAL_IRQ_EPILOGUE();
+}
+
+/**
+ * @brief EXTI[2]...EXTI[3] interrupt handler.
+ *
+ * @isr
+ */
+OSAL_IRQ_HANDLER(Vector58) {
+ uint32_t pr;
+
+ OSAL_IRQ_PROLOGUE();
+
+ pr = EXTI->PR;
+ pr &= ((1U << 2) | (1U << 3));
+ EXTI->PR = pr;
+
+ exti_serve_irq(pr, 2);
+ exti_serve_irq(pr, 3);
+
+ OSAL_IRQ_EPILOGUE();
+}
+
+/**
+ * @brief EXTI[4]...EXTI[15] interrupt handler.
+ *
+ * @isr
+ */
+OSAL_IRQ_HANDLER(Vector5C) {
+ uint32_t pr;
+
+ OSAL_IRQ_PROLOGUE();
+
+ pr = EXTI->PR;
+ pr &= ((1U << 4) | (1U << 5) | (1U << 6) | (1U << 7) | (1U << 8) |
+ (1U << 9) | (1U << 10) | (1U << 11) | (1U << 12) | (1U << 13) |
+ (1U << 14) | (1U << 15));
+ EXTI->PR = pr;
+
+ exti_serve_irq(pr, 4);
+ exti_serve_irq(pr, 5);
+ exti_serve_irq(pr, 6);
+ exti_serve_irq(pr, 7);
+ exti_serve_irq(pr, 8);
+ exti_serve_irq(pr, 9);
+ exti_serve_irq(pr, 10);
+ exti_serve_irq(pr, 11);
+ exti_serve_irq(pr, 12);
+ exti_serve_irq(pr, 13);
+ exti_serve_irq(pr, 14);
+ exti_serve_irq(pr, 15);
+
+ OSAL_IRQ_EPILOGUE();
+}
+
+#endif /* HAL_USE_PAL */
+
+/*===========================================================================*/
+/* Driver exported functions. */
+/*===========================================================================*/
+
+/**
+ * @brief Enables IRQ sources.
+ *
+ * @notapi
+ */
+void irqInit(void) {
+
+#if HAL_USE_PAL
+ nvicEnableVector(STM32_EXTI_LINE01_NUMBER, STM32_IRQ_EXTI0_1_PRIORITY);
+ nvicEnableVector(STM32_EXTI_LINE23_NUMBER, STM32_IRQ_EXTI2_3_PRIORITY);
+ nvicEnableVector(STM32_EXTI_LINE4_15_NUMBER, STM32_IRQ_EXTI4_15_PRIORITY);
+ nvicEnableVector(STM32_EXTI_LINE16_NUMBER, STM32_IRQ_EXTI16_PRIORITY);
+#endif
+}
+
+/**
+ * @brief Disables IRQ sources.
+ *
+ * @notapi
+ */
+void irqDeinit(void) {
+
+#if HAL_USE_PAL
+ nvicDisableVector(STM32_EXTI_LINE01_NUMBER);
+ nvicDisableVector(STM32_EXTI_LINE23_NUMBER);
+ nvicDisableVector(STM32_EXTI_LINE4_15_NUMBER);
+ nvicDisableVector(STM32_EXTI_LINE16_NUMBER);
+ nvicDisableVector(STM32_EXTI_LINE2122_NUMBER);
+#endif
+}
+
+/** @} */
diff --git a/os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.h b/os/hal/ports/STM32/STM32L0xx/stm32_isr.h
index e7465b00a..830334dff 100644
--- a/os/hal/ports/STM32/STM32L0xx/hal_ext_lld_isr.h
+++ b/os/hal/ports/STM32/STM32L0xx/stm32_isr.h
@@ -15,17 +15,15 @@
*/
/**
- * @file STM32L0xx/hal_ext_lld_isr.h
- * @brief STM32L0xx EXT subsystem low level driver ISR header.
+ * @file STM32L0xx/stm32_isr.h
+ * @brief STM32L0xx ISR handler header.
*
- * @addtogroup EXT
+ * @addtogroup STM32L0xx_ISR
* @{
*/
-#ifndef HAL_EXT_LLD_ISR_H
-#define HAL_EXT_LLD_ISR_H
-
-#if HAL_USE_EXT || defined(__DOXYGEN__)
+#ifndef STM32_ISR_H
+#define STM32_ISR_H
/*===========================================================================*/
/* Driver constants. */
@@ -42,43 +40,43 @@
/**
* @brief EXTI0..1 interrupt priority level setting.
*/
-#if !defined(STM32_EXT_EXTI0_1_IRQ_PRIORITY) || defined(__DOXYGEN__)
-#define STM32_EXT_EXTI0_1_IRQ_PRIORITY 3
+#if !defined(STM32_IRQ_EXTI0_1_PRIORITY) || defined(__DOXYGEN__)
+#define STM32_IRQ_EXTI0_1_PRIORITY 3
#endif
/**
* @brief EXTI2..3 interrupt priority level setting.
*/
-#if !defined(STM32_EXT_EXTI2_3_IRQ_PRIORITY) || defined(__DOXYGEN__)
-#define STM32_EXT_EXTI2_3_IRQ_PRIORITY 3
+#if !defined(STM32_IRQ_EXTI2_3_PRIORITY) || defined(__DOXYGEN__)
+#define STM32_IRQ_EXTI2_3_PRIORITY 3
#endif
/**
* @brief EXTI4..15 interrupt priority level setting.
*/
-#if !defined(STM32_EXT_EXTI4_15_IRQ_PRIORITY) || defined(__DOXYGEN__)
-#define STM32_EXT_EXTI4_15_IRQ_PRIORITY 3
+#if !defined(STM32_IRQ_EXTI4_15_PRIORITY) || defined(__DOXYGEN__)
+#define STM32_IRQ_EXTI4_15_PRIORITY 3
#endif
/**
* @brief EXTI16 (PVD) interrupt priority level setting.
*/
-#if !defined(STM32_EXT_EXTI16_IRQ_PRIORITY) || defined(__DOXYGEN__)
-#define STM32_EXT_EXTI16_IRQ_PRIORITY 3
+#if !defined(STM32_IRQ_EXTI16_PRIORITY) || defined(__DOXYGEN__)
+#define STM32_IRQ_EXTI16_PRIORITY 3
#endif
/**
* @brief EXTI17,19,20 interrupt priority level setting.
*/
-#if !defined(STM32_EXT_EXTI17_20_IRQ_PRIORITY) || defined(__DOXYGEN__)
-#define STM32_EXT_EXTI17_20_IRQ_PRIORITY 3
+#if !defined(STM32_IRQ_EXTI17_20_PRIORITY) || defined(__DOXYGEN__)
+#define STM32_IRQ_EXTI17_20_PRIORITY 3
#endif
/**
* @brief EXTI21,22 interrupt priority level setting.
*/
-#if !defined(STM32_EXT_EXTI21_22_IRQ_PRIORITY) || defined(__DOXYGEN__)
-#define STM32_EXT_EXTI21_22_IRQ_PRIORITY 3
+#if !defined(STM32_IRQ_EXTI21_22_PRIORITY) || defined(__DOXYGEN__)
+#define STM32_IRQ_EXTI21_22_PRIORITY 3
#endif
/** @} */
@@ -101,14 +99,12 @@
#ifdef __cplusplus
extern "C" {
#endif
- void ext_lld_exti_irq_enable(void);
- void ext_lld_exti_irq_disable(void);
+ void irqInit(void);
+ void irqDeinit(void);
#ifdef __cplusplus
}
#endif
-#endif /* HAL_USE_EXT */
-
-#endif /* HAL_EXT_LLD_ISR_H */
+#endif /* STM32_ISR_H */
/** @} */