aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F4xx
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2019-01-05 15:49:50 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2019-01-05 15:49:50 +0000
commitb470e1ae0feb1d173465f8083248ad4324755592 (patch)
tree89eeb538bf0871730aa890c37b042988f7929654 /os/hal/ports/STM32/STM32F4xx
parent90ddeb9ef88675bfd5cc84be3c2ee215f9404720 (diff)
downloadChibiOS-b470e1ae0feb1d173465f8083248ad4324755592.tar.gz
ChibiOS-b470e1ae0feb1d173465f8083248ad4324755592.tar.bz2
ChibiOS-b470e1ae0feb1d173465f8083248ad4324755592.zip
Improved search of configuration files.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@12529 110e8d01-0319-4d1e-a829-52ad28d1bb01
Diffstat (limited to 'os/hal/ports/STM32/STM32F4xx')
-rw-r--r--os/hal/ports/STM32/STM32F4xx/platform.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/os/hal/ports/STM32/STM32F4xx/platform.mk b/os/hal/ports/STM32/STM32F4xx/platform.mk
index 2b039dd46..7b5cd41b4 100644
--- a/os/hal/ports/STM32/STM32F4xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F4xx/platform.mk
@@ -11,11 +11,15 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
ifeq ($(USE_SMART_BUILD),yes)
# Configuration files directory
-ifeq ($(CONFDIR),)
- CONFDIR = .
+ifeq ($(HALCONFDIR),)
+ ifeq ($(CONFDIR),)
+ HALCONFDIR = .
+ else
+ HALCONFDIR := $(CONFDIR)
+ endif
endif
-HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
+HALCONF := $(strip $(shell cat $(HALCONFDIR)/halconf.h | egrep -e "\#define"))
else
endif