aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F37x
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2019-03-17 13:16:01 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2019-03-17 13:16:01 +0000
commit71a12f97d5c6ec2d926c67c9bc100f3b2fa3950d (patch)
tree92d6828ac96b147b6c8f3b1c2cb46fc1fe822804 /os/hal/ports/STM32/STM32F37x
parent7e9ca62aad5269d7feb486797500cba091f7ea36 (diff)
downloadChibiOS-71a12f97d5c6ec2d926c67c9bc100f3b2fa3950d.tar.gz
ChibiOS-71a12f97d5c6ec2d926c67c9bc100f3b2fa3950d.tar.bz2
ChibiOS-71a12f97d5c6ec2d926c67c9bc100f3b2fa3950d.zip
Fixed bug #1022.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/branches/stable_19.1.x@12709 27425a3e-05d8-49a3-a47f-9c15f0e5edd8
Diffstat (limited to 'os/hal/ports/STM32/STM32F37x')
-rw-r--r--os/hal/ports/STM32/STM32F37x/hal_lld.h1
-rw-r--r--os/hal/ports/STM32/STM32F37x/platform.mk1
-rw-r--r--os/hal/ports/STM32/STM32F37x/stm32_registry.h4
3 files changed, 4 insertions, 2 deletions
diff --git a/os/hal/ports/STM32/STM32F37x/hal_lld.h b/os/hal/ports/STM32/STM32F37x/hal_lld.h
index 7dbdfbf57..82e46b8cc 100644
--- a/os/hal/ports/STM32/STM32F37x/hal_lld.h
+++ b/os/hal/ports/STM32/STM32F37x/hal_lld.h
@@ -993,6 +993,7 @@
#include "stm32_registry.h"
#include "stm32_isr.h"
#include "stm32_dma.h"
+#include "stm32_exti.h"
#include "stm32_rcc.h"
#ifdef __cplusplus
diff --git a/os/hal/ports/STM32/STM32F37x/platform.mk b/os/hal/ports/STM32/STM32F37x/platform.mk
index 6fa673330..f807d3dae 100644
--- a/os/hal/ports/STM32/STM32F37x/platform.mk
+++ b/os/hal/ports/STM32/STM32F37x/platform.mk
@@ -32,6 +32,7 @@ endif
include $(CHIBIOS)/os/hal/ports/STM32/LLD/CANv1/driver.mk
include $(CHIBIOS)/os/hal/ports/STM32/LLD/DACv1/driver.mk
include $(CHIBIOS)/os/hal/ports/STM32/LLD/DMAv1/driver.mk
+include $(CHIBIOS)/os/hal/ports/STM32/LLD/EXTIv1/driver.mk
include $(CHIBIOS)/os/hal/ports/STM32/LLD/GPIOv2/driver.mk
include $(CHIBIOS)/os/hal/ports/STM32/LLD/I2Cv2/driver.mk
include $(CHIBIOS)/os/hal/ports/STM32/LLD/RTCv2/driver.mk
diff --git a/os/hal/ports/STM32/STM32F37x/stm32_registry.h b/os/hal/ports/STM32/STM32F37x/stm32_registry.h
index c2729188a..b5fe4f32a 100644
--- a/os/hal/ports/STM32/STM32F37x/stm32_registry.h
+++ b/os/hal/ports/STM32/STM32F37x/stm32_registry.h
@@ -103,7 +103,7 @@
/* EXTI attributes.*/
#define STM32_EXTI_NUM_LINES 23
-#define STM32_EXTI_IMR_MASK 0x1F800000U
+#define STM32_EXTI_IMR1_MASK 0x1F800000U
/* GPIO attributes.*/
#define STM32_HAS_GPIOA TRUE
@@ -356,7 +356,7 @@
/* EXTI attributes.*/
#define STM32_EXTI_NUM_LINES 23
-#define STM32_EXTI_IMR_MASK 0x1F800000U
+#define STM32_EXTI_IMR1_MASK 0x1F800000U
/* GPIO attributes.*/
#define STM32_HAS_GPIOA TRUE