aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F1xx
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-08-02 14:25:05 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-08-02 14:25:05 +0000
commit40b6d76453be91a5b8998c19db80ccd57b5b1653 (patch)
tree4c72363680f260f43cfc78077c2b06f3d74682d4 /os/hal/ports/STM32/STM32F1xx
parent9058939dbe67670b079204d3b1ae337cf7d3cf60 (diff)
downloadChibiOS-40b6d76453be91a5b8998c19db80ccd57b5b1653.tar.gz
ChibiOS-40b6d76453be91a5b8998c19db80ccd57b5b1653.tar.bz2
ChibiOS-40b6d76453be91a5b8998c19db80ccd57b5b1653.zip
Added to the Makefiles the ability to change the default build, dependencies and configuration directories.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10350 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/STM32F1xx')
-rw-r--r--os/hal/ports/STM32/STM32F1xx/platform.mk8
-rw-r--r--os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk8
2 files changed, 14 insertions, 2 deletions
diff --git a/os/hal/ports/STM32/STM32F1xx/platform.mk b/os/hal/ports/STM32/STM32F1xx/platform.mk
index 216724585..b115aafc3 100644
--- a/os/hal/ports/STM32/STM32F1xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F1xx/platform.mk
@@ -8,7 +8,13 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
# Optional platform files.
ifeq ($(USE_SMART_BUILD),yes)
-HALCONF := $(strip $(shell cat halconf.h | egrep -e "\#define"))
+
+# Configuration files directory
+ifeq ($(CONFDIR),)
+ CONFDIR = .
+endif
+
+HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_ext_lld_isr.c
diff --git a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
index 8c4eb980e..719457e83 100644
--- a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
+++ b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
@@ -8,7 +8,13 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
# Optional platform files.
ifeq ($(USE_SMART_BUILD),yes)
-HALCONF := $(strip $(shell cat halconf.h | egrep -e "\#define"))
+
+# Configuration files directory
+ifeq ($(CONFDIR),)
+ CONFDIR = .
+endif
+
+HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_ext_lld_isr.c