aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2015-09-21 11:01:37 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2015-09-21 11:01:37 +0000
commitd25139221ec71ed2fbd6a9e06aa3c039c6cf9551 (patch)
treee6fb0a405d279172932c17846a4a21d89747b5da /os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
parentb0732341df29179f7dfc1adfab99bb3a11e1c065 (diff)
downloadChibiOS-d25139221ec71ed2fbd6a9e06aa3c039c6cf9551.tar.gz
ChibiOS-d25139221ec71ed2fbd6a9e06aa3c039c6cf9551.tar.bz2
ChibiOS-d25139221ec71ed2fbd6a9e06aa3c039c6cf9551.zip
Fixed bug #609.
Updated STM32F1xx headers. STM32F1xx, STM32F3xx and STM32F37x now use the common DMAv1 driver. git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@8319 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk')
-rw-r--r--os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
index 446179a3a..ddf8a2156 100644
--- a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
+++ b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
@@ -3,8 +3,8 @@ ifeq ($(USE_SMART_BUILD),yes)
HALCONF := $(strip $(shell cat halconf.h | egrep -e "define"))
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
- $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/stm32_dma.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/DMAv1/stm32_dma.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/TIMv1/st_lld.c
ifneq ($(findstring HAL_USE_ADC TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/adc_lld.c
@@ -57,12 +57,12 @@ PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/USARTv1/uart_lld.c
endif
else
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
- $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/stm32_dma.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/adc_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/ext_lld_isr.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/CANv1/can_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/DACv1/dac_lld.c \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/DMAv1/stm32_dma.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/EXTIv1/ext_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/GPIOv1/pal_lld.c \
$(CHIBIOS)/os/hal/ports/STM32/LLD/I2Cv1/i2c_lld.c \
@@ -83,6 +83,7 @@ endif
PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
$(CHIBIOS)/os/hal/ports/STM32/STM32F1xx \
$(CHIBIOS)/os/hal/ports/STM32/LLD/DACv1 \
+ $(CHIBIOS)/os/hal/ports/STM32/LLD/DMAv1 \
$(CHIBIOS)/os/hal/ports/STM32/LLD/EXTIv1 \
$(CHIBIOS)/os/hal/ports/STM32/LLD/GPIOv1 \
$(CHIBIOS)/os/hal/ports/STM32/LLD/I2Cv1 \