aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-09-02 10:18:15 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-09-02 10:18:15 +0000
commit7f5380a8a5f9f9e8a39b59d6896ef9c79cc7a0f9 (patch)
treec50a347ba44e4d451e654a8686b006da9832b88b /os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
parent4c39135c94232e76011da8a055dd3eddd0031da2 (diff)
downloadChibiOS-7f5380a8a5f9f9e8a39b59d6896ef9c79cc7a0f9.tar.gz
ChibiOS-7f5380a8a5f9f9e8a39b59d6896ef9c79cc7a0f9.tar.bz2
ChibiOS-7f5380a8a5f9f9e8a39b59d6896ef9c79cc7a0f9.zip
PAL callbacks added to STM32F103
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10526 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk')
-rw-r--r--os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
index 719457e83..35cd7221e 100644
--- a/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
+++ b/os/hal/ports/STM32/STM32F1xx/platform_f105_f107.mk
@@ -1,5 +1,6 @@
# Required platform files.
PLATFORMSRC := $(CHIBIOS)/os/hal/ports/common/ARMCMx/nvic.c \
+ $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/stm32_isr.c \
$(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_lld.c
# Required include directories.
@@ -16,15 +17,11 @@ endif
HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
-ifneq ($(findstring HAL_USE_EXT TRUE,$(HALCONF)),)
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_ext_lld_isr.c
-endif
ifneq ($(findstring HAL_USE_ADC TRUE,$(HALCONF)),)
PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_adc_lld.c
endif
else
-PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_ext_lld_isr.c \
- $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_adc_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/STM32F1xx/hal_adc_lld.c
endif
# Drivers compatible with the platform.