aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/LLD/SPIv3/driver.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-12-26 13:18:16 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-12-26 13:18:16 +0000
commit8b719ae5594bb8f667794a3f129f509a74bf5a12 (patch)
tree2204febe1ef205a7fdc4696d121415edb85524d4 /os/hal/ports/STM32/LLD/SPIv3/driver.mk
parentdc3872cef8b0340421c8f948665cbe7d38798ae4 (diff)
downloadChibiOS-8b719ae5594bb8f667794a3f129f509a74bf5a12.tar.gz
ChibiOS-8b719ae5594bb8f667794a3f129f509a74bf5a12.tar.bz2
ChibiOS-8b719ae5594bb8f667794a3f129f509a74bf5a12.zip
Added stub DMA and SPI drivers for H7.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@11191 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/LLD/SPIv3/driver.mk')
-rw-r--r--os/hal/ports/STM32/LLD/SPIv3/driver.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/os/hal/ports/STM32/LLD/SPIv3/driver.mk b/os/hal/ports/STM32/LLD/SPIv3/driver.mk
new file mode 100644
index 000000000..f8779c133
--- /dev/null
+++ b/os/hal/ports/STM32/LLD/SPIv3/driver.mk
@@ -0,0 +1,13 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_I2S TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv3/hal_i2s_lld.c
+endif
+ifneq ($(findstring HAL_USE_SPI TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv3/hal_spi_lld.c
+endif
+else
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv3/hal_i2s_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv3/hal_spi_lld.c
+endif
+
+PLATFORMINC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SPIv3