aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/LLD/SDMMCv1
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2017-01-16 12:11:04 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2017-01-16 12:11:04 +0000
commitce7f9addf21d84566a95df6d975d74431854b5ea (patch)
tree2124d919c4fcfae762ecda9da3685535db978f61 /os/hal/ports/STM32/LLD/SDMMCv1
parent9a3437d8f0a4b9b16db1d838f597da50d3ec75f2 (diff)
downloadChibiOS-ce7f9addf21d84566a95df6d975d74431854b5ea.tar.gz
ChibiOS-ce7f9addf21d84566a95df6d975d74431854b5ea.tar.bz2
ChibiOS-ce7f9addf21d84566a95df6d975d74431854b5ea.zip
Introduced modularized driver makefiles.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10053 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/STM32/LLD/SDMMCv1')
-rw-r--r--os/hal/ports/STM32/LLD/SDMMCv1/driver.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/os/hal/ports/STM32/LLD/SDMMCv1/driver.mk b/os/hal/ports/STM32/LLD/SDMMCv1/driver.mk
new file mode 100644
index 000000000..7edbc2438
--- /dev/null
+++ b/os/hal/ports/STM32/LLD/SDMMCv1/driver.mk
@@ -0,0 +1,9 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_SDC TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SDMMCv1/hal_sdc_lld.c
+endif
+else
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SDMMCv1/hal_sdc_lld.c
+endif
+
+PLATFORMINC += $(CHIBIOS)/os/hal/ports/STM32/LLD/SDMMCv1