aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/SPC5/SPC56ELxx/platform.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-09-22 12:43:39 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-09-22 12:43:39 +0000
commite9ffaf9bdc231c69adffd5486c2949f21390e6e1 (patch)
tree6e70b0f2705345ca8a6d354dab9364ce07529659 /os/hal/ports/SPC5/SPC56ELxx/platform.mk
parentc0a616c52b6c00aeee8917329bf8659d3062a7bc (diff)
downloadChibiOS-e9ffaf9bdc231c69adffd5486c2949f21390e6e1.tar.gz
ChibiOS-e9ffaf9bdc231c69adffd5486c2949f21390e6e1.tar.bz2
ChibiOS-e9ffaf9bdc231c69adffd5486c2949f21390e6e1.zip
Forked SPC5 drivers from SPC5-HAL project, not all of them, just the one needed for supporting the PPC port.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10679 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/SPC5/SPC56ELxx/platform.mk')
-rw-r--r--os/hal/ports/SPC5/SPC56ELxx/platform.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/os/hal/ports/SPC5/SPC56ELxx/platform.mk b/os/hal/ports/SPC5/SPC56ELxx/platform.mk
new file mode 100644
index 000000000..72d862bd1
--- /dev/null
+++ b/os/hal/ports/SPC5/SPC56ELxx/platform.mk
@@ -0,0 +1,21 @@
+# List of all the SPC56ELxx platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/SPC5/SPC56ELxx/hal_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/EDMA_v1/spc5_edma.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/FlexCAN_v1/hal_can_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/eTimer_v1/hal_icu_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/SIUL_v1/hal_pal_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/FlexPWM_v1/hal_pwm_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/LINFlex_v1/hal_serial_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/DSPI_v1/hal_spi_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/STM_v1/hal_st_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/SPC5/SPC56ELxx \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/EDMA_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/FlexCAN_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/eTimer_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/SIUL_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/FlexPWM_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/LINFlex_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/DSPI_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/STM_v1