aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/SPC5/SPC560BCxx/platform.mk
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2017-12-07 10:09:39 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2017-12-07 10:09:39 +0000
commit357a01573d4ddeb8f0a5867970eb5c5cb13b4c9a (patch)
treee00af91996351c1bc6b4847bcf4d2bcd01dfde4b /os/hal/ports/SPC5/SPC560BCxx/platform.mk
parent6dc0868aa57b2efdabf4a5e4d5be184165aeec9d (diff)
downloadChibiOS-357a01573d4ddeb8f0a5867970eb5c5cb13b4c9a.tar.gz
ChibiOS-357a01573d4ddeb8f0a5867970eb5c5cb13b4c9a.tar.bz2
ChibiOS-357a01573d4ddeb8f0a5867970eb5c5cb13b4c9a.zip
Removed unsupported drivers.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@11130 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/SPC5/SPC560BCxx/platform.mk')
-rw-r--r--os/hal/ports/SPC5/SPC560BCxx/platform.mk27
1 files changed, 10 insertions, 17 deletions
diff --git a/os/hal/ports/SPC5/SPC560BCxx/platform.mk b/os/hal/ports/SPC5/SPC560BCxx/platform.mk
index af702f9aa..6bab00ad1 100644
--- a/os/hal/ports/SPC5/SPC560BCxx/platform.mk
+++ b/os/hal/ports/SPC5/SPC560BCxx/platform.mk
@@ -1,25 +1,18 @@
# List of all the SPC560BCxx platform files.
PLATFORMSRC = ${CHIBIOS}/os/hal/ports/SPC5/SPC560BCxx/hal_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/EDMA_v1/spc5_edma.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/ADC_v1/hal_adc_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/eMIOS_v1/spc5_emios.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/eMIOS_v1/hal_icu_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/eMIOS_v1/hal_pwm_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/FlexCAN_v1/hal_can_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/SIUL_v1/hal_pal_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/LINFlex_v1/hal_serial_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/DSPI_v1/hal_spi_lld.c \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/STM_v1/hal_st_lld.c
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/EDMA_v1/spc5_edma.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/SIUL_v1/hal_pal_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/LINFlex_v1/hal_serial_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/DSPI_v1/hal_spi_lld.c \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/STM_v1/hal_st_lld.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/SPC5/SPC560BCxx \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/EDMA_v1 \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/FlexCAN_v1 \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/SIUL_v1 \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/eMIOS_v1 \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/LINFlex_v1 \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/DSPI_v1 \
- ${CHIBIOS}/os/hal/ports/SPC5/SPC5xx/STM_v1
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/EDMA_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/SIUL_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/LINFlex_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/DSPI_v1 \
+ ${CHIBIOS}/os/hal/ports/SPC5/LLD/STM_v1
# Shared variables
ALLCSRC += $(PLATFORMSRC)