aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/KINETIS/K20x
diff options
context:
space:
mode:
authorutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-09-01 00:15:37 +0000
committerutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-09-01 00:15:37 +0000
commitdd508d96177b7f139986bf88d7d6cf222802ac58 (patch)
treeeb78724ea1f1ea250ff9dc2a015349aae67d6eec /os/hal/ports/KINETIS/K20x
parent9ace2f7d410437cc4a88b451f4a88ebc442528c2 (diff)
downloadChibiOS-dd508d96177b7f139986bf88d7d6cf222802ac58.tar.gz
ChibiOS-dd508d96177b7f139986bf88d7d6cf222802ac58.tar.bz2
ChibiOS-dd508d96177b7f139986bf88d7d6cf222802ac58.zip
[KINETIS] Move to standardized port skel
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@7216 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/KINETIS/K20x')
-rw-r--r--os/hal/ports/KINETIS/K20x/hal_lld.h3
-rw-r--r--os/hal/ports/KINETIS/K20x/kinetis_registry.h49
-rw-r--r--os/hal/ports/KINETIS/K20x/platform.mk7
3 files changed, 54 insertions, 5 deletions
diff --git a/os/hal/ports/KINETIS/K20x/hal_lld.h b/os/hal/ports/KINETIS/K20x/hal_lld.h
index b2939df0b..f7b690308 100644
--- a/os/hal/ports/KINETIS/K20x/hal_lld.h
+++ b/os/hal/ports/KINETIS/K20x/hal_lld.h
@@ -1,5 +1,5 @@
/*
- ChibiOS/RT - Copyright (C) 2006-2014 Giovanni Di Sirio
+ ChibiOS/RT - Copyright (C) 2014 Fabio Utzig
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -26,6 +26,7 @@
#define _HAL_LLD_H_
#include "mk20d5.h"
+#include "kinetis_registry.h"
/*===========================================================================*/
/* Driver constants. */
diff --git a/os/hal/ports/KINETIS/K20x/kinetis_registry.h b/os/hal/ports/KINETIS/K20x/kinetis_registry.h
new file mode 100644
index 000000000..004049cc7
--- /dev/null
+++ b/os/hal/ports/KINETIS/K20x/kinetis_registry.h
@@ -0,0 +1,49 @@
+/*
+ ChibiOS/HAL - Copyright (C) 2014 Fabio Utzig
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/**
+ * @file KL2x/kinetis_registry.h
+ * @brief KL2x capabilities registry.
+ *
+ * @addtogroup HAL
+ * @{
+ */
+
+#ifndef _KINETIS_REGISTRY_H_
+#define _KINETIS_REGISTRY_H_
+
+/*===========================================================================*/
+/* Platform capabilities. */
+/*===========================================================================*/
+
+/**
+ * @name KL2x capabilities
+ * @{
+ */
+/* EXT attributes.*/
+
+#define KINETIS_PORTA_IRQ_VECTOR VectorE0
+#define KINETIS_PORTB_IRQ_VECTOR VectorE4
+#define KINETIS_PORTC_IRQ_VECTOR VectorE8
+#define KINETIS_PORTD_IRQ_VECTOR VectorEC
+#define KINETIS_PORTE_IRQ_VECTOR VectorF0
+
+
+/** @} */
+
+#endif /* _KINETIS_REGISTRY_H_ */
+
+/** @} */
diff --git a/os/hal/ports/KINETIS/K20x/platform.mk b/os/hal/ports/KINETIS/K20x/platform.mk
index afe7c21ad..1052adc65 100644
--- a/os/hal/ports/KINETIS/K20x/platform.mk
+++ b/os/hal/ports/KINETIS/K20x/platform.mk
@@ -5,11 +5,10 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS}/os/hal/ports/KINETIS/K20x/serial_lld.c \
${CHIBIOS}/os/hal/ports/KINETIS/K20x/spi_lld.c \
${CHIBIOS}/os/hal/ports/KINETIS/K20x/i2c_lld.c \
+ ${CHIBIOS}/os/hal/ports/KINETIS/LLD/ext_lld.c \
${CHIBIOS}/os/hal/ports/KINETIS/K20x/st_lld.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
- ${CHIBIOS}/os/hal/ports/KINETIS/K20x
-
-
-
+ ${CHIBIOS}/os/hal/ports/KINETIS/K20x \
+ ${CHIBIOS}/os/hal/ports/KINETIS/LLD