aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/AVR/platform.mk
diff options
context:
space:
mode:
authorutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-06-29 23:06:17 +0000
committerutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-06-29 23:06:17 +0000
commit766a2388d46f49e07ec0280fa4f3d254367850d1 (patch)
treef7c116f3a638a861575a16467703ad19fd26255c /os/hal/ports/AVR/platform.mk
parent5eb1ae8cc3f4d2584d31e2d9672162bf8bfc0274 (diff)
downloadChibiOS-766a2388d46f49e07ec0280fa4f3d254367850d1.tar.gz
ChibiOS-766a2388d46f49e07ec0280fa4f3d254367850d1.tar.bz2
ChibiOS-766a2388d46f49e07ec0280fa4f3d254367850d1.zip
AVR HAL ported from RT-2 (serial/pal/hal tested)
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@6999 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/AVR/platform.mk')
-rw-r--r--os/hal/ports/AVR/platform.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/os/hal/ports/AVR/platform.mk b/os/hal/ports/AVR/platform.mk
new file mode 100644
index 000000000..d91d334ff
--- /dev/null
+++ b/os/hal/ports/AVR/platform.mk
@@ -0,0 +1,14 @@
+# List of all the AVR platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/AVR/hal_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/pal_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/serial_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/adc_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/i2c_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/spi_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/gpt_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/pwm_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/icu_lld.c \
+ ${CHIBIOS}/os/hal/ports/AVR/st_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/AVR