aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk
diff options
context:
space:
mode:
authorTheodore Ateba <tf.ateba@gmail.com>2017-08-13 14:18:30 +0000
committerTheodore Ateba <tf.ateba@gmail.com>2017-08-13 14:18:30 +0000
commit0879845f96744ce1c0548d3abeb55c392ef47c00 (patch)
treee5c0cbbe028f7bad6fc023c962bff3c6d463ae5b /os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk
parentcd06f9a246cf6c5d7009712d815dacf1632ffd64 (diff)
downloadChibiOS-0879845f96744ce1c0548d3abeb55c392ef47c00.tar.gz
ChibiOS-0879845f96744ce1c0548d3abeb55c392ef47c00.tar.bz2
ChibiOS-0879845f96744ce1c0548d3abeb55c392ef47c00.zip
Update the AVR Tiny Architecture.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10412 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk')
-rw-r--r--os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk b/os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk
new file mode 100644
index 000000000..982db5635
--- /dev/null
+++ b/os/hal/ports/AVR/TINY/LLD/TIMv1/driver.mk
@@ -0,0 +1,19 @@
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1/hal_st_lld.c
+
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_GPT TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.c
+endif
+ifneq ($(findstring HAL_USE_ICU TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.c
+endif
+ifneq ($(findstring HAL_USE_PWM TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.c
+endif
+else
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1/hal_gpt_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1/hal_icu_lld.c
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1/hal_pwm_lld.c
+endif
+
+PLATFORMINC += $(CHIBIOS)/os/hal/ports/AVR/TINY/TIMv1