aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/AVR/MEGA/LLD/SPIv1
diff options
context:
space:
mode:
authorTheodore Ateba <tf.ateba@gmail.com>2017-08-16 06:38:35 +0000
committerTheodore Ateba <tf.ateba@gmail.com>2017-08-16 06:38:35 +0000
commit81208fd6bec3dd581cd29ce05f7be988dba9b8fb (patch)
tree2a3c043d8a35d49b01131e2235c44b546a6d8707 /os/hal/ports/AVR/MEGA/LLD/SPIv1
parent2ec713733e3b260987b38e3b7dc6cbb4ba3c5623 (diff)
downloadChibiOS-81208fd6bec3dd581cd29ce05f7be988dba9b8fb.tar.gz
ChibiOS-81208fd6bec3dd581cd29ce05f7be988dba9b8fb.tar.bz2
ChibiOS-81208fd6bec3dd581cd29ce05f7be988dba9b8fb.zip
Add low level driver directory and platfor for AVR MEGA.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@10431 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/hal/ports/AVR/MEGA/LLD/SPIv1')
-rw-r--r--os/hal/ports/AVR/MEGA/LLD/SPIv1/driver.mk9
-rw-r--r--os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.c344
-rw-r--r--os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.h257
3 files changed, 610 insertions, 0 deletions
diff --git a/os/hal/ports/AVR/MEGA/LLD/SPIv1/driver.mk b/os/hal/ports/AVR/MEGA/LLD/SPIv1/driver.mk
new file mode 100644
index 000000000..0f98a1a62
--- /dev/null
+++ b/os/hal/ports/AVR/MEGA/LLD/SPIv1/driver.mk
@@ -0,0 +1,9 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_SPI TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/MEGA/SPIv1/hal_spi_lld.c
+endif
+else
+PLATFORMSRC += $(CHIBIOS)/os/hal/ports/AVR/MEGA/SPIv1/hal_spi_lld.c
+endif
+
+PLATFORMINC += $(CHIBIOS)/os/hal/ports/AVR/MEGA/SPIv1
diff --git a/os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.c b/os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.c
new file mode 100644
index 000000000..a9bb13228
--- /dev/null
+++ b/os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.c
@@ -0,0 +1,344 @@
+/*
+ ChibiOS - Copyright (C) 2006..2016 Giovanni Di Sirio
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/**
+ * @file hal_spi_lld.c
+ * @brief AVR SPI subsystem low level driver source.
+ *
+ * @addtogroup SPI
+ * @{
+ */
+
+#include "hal.h"
+
+#if HAL_USE_SPI || defined(__DOXYGEN__)
+
+/*===========================================================================*/
+/* Driver local definitions. */
+/*===========================================================================*/
+
+#define DUMMY_SPI_SEND_VALUE 0xFF
+
+/*===========================================================================*/
+/* Driver exported variables. */
+/*===========================================================================*/
+
+/**
+ * @brief SPI1 driver identifier.
+ */
+#if AVR_SPI_USE_SPI1 || defined(__DOXYGEN__)
+SPIDriver SPID1;
+#endif
+
+/*===========================================================================*/
+/* Driver local variables and types. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver local functions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver interrupt handlers. */
+/*===========================================================================*/
+
+#if AVR_SPI_USE_SPI1 || defined(__DOXYGEN__)
+/**
+ * @brief SPI event interrupt handler.
+ *
+ * @notapi
+ */
+OSAL_IRQ_HANDLER(SPI_STC_vect) {
+ OSAL_IRQ_PROLOGUE();
+
+ SPIDriver *spip = &SPID1;
+
+ /* a new value has arrived, store it if we are interested in it */
+ if (spip->rxbuf) spip->rxbuf[spip->exidx] = SPDR;
+
+ /* check if we are done */
+ if (++(spip->exidx) >= spip->exbytes) {
+ _spi_isr_code(spip);
+ } else { /* if not done send the next byte */
+ if (spip->txbuf) { /* if there is a buffer with values to be send then use it*/
+ SPDR = spip->txbuf[spip->exidx];
+ } else { /* if there isn't a buffer with values to be send then send a the dummy value*/
+ SPDR = DUMMY_SPI_SEND_VALUE;
+ }
+ }
+ OSAL_IRQ_EPILOGUE();
+}
+#endif /* AVR_SPI_USE_SPI1 */
+
+/*===========================================================================*/
+/* Driver exported functions. */
+/*===========================================================================*/
+
+/**
+ * @brief Low level SPI driver initialization.
+ *
+ * @notapi
+ */
+void spi_lld_init(void) {
+
+#if AVR_SPI_USE_SPI1
+ /* Driver initialization.*/
+ spiObjectInit(&SPID1);
+#endif /* AVR_SPI_USE_SPI1 */
+}
+
+/**
+ * @brief Configures and activates the SPI peripheral.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ *
+ * @notapi
+ */
+void spi_lld_start(SPIDriver *spip) {
+
+ uint8_t dummy;
+
+ /* Configures the peripheral.*/
+
+ if (spip->state == SPI_STOP) {
+ /* Enables the peripheral.*/
+#if AVR_SPI_USE_SPI1
+ if (&SPID1 == spip) {
+ /* Enable SPI clock using Power Reduction Register */
+#if defined(PRR0)
+ PRR0 &= ~(1 << PRSPI);
+#elif defined(PRR)
+ PRR &= ~(1 << PRSPI);
+#endif
+
+ /* SPI enable, SPI interrupt enable */
+ SPCR |= ((1 << SPE) | (1 << SPIE));
+
+ SPCR |= (1 << MSTR);
+ DDR_SPI1 |= ((1 << SPI1_MOSI) | (1 << SPI1_SCK));
+ DDR_SPI1 &= ~(1 << SPI1_MISO);
+ spip->config->ssport->dir |= (1 << spip->config->sspad);
+
+ switch (spip->config->bitorder) {
+ case SPI_LSB_FIRST:
+ SPCR |= (1 << DORD);
+ break;
+ case SPI_MSB_FIRST: /* fallthrough */
+ default:
+ SPCR &= ~(1 << DORD);
+ break;
+ }
+
+ SPCR &= ~((1 << CPOL) | (1 << CPHA));
+ switch (spip->config->mode) {
+ case SPI_MODE_1:
+ SPCR |= (1 << CPHA);
+ break;
+ case SPI_MODE_2:
+ SPCR |= (1 << CPOL);
+ break;
+ case SPI_MODE_3:
+ SPCR |= ((1 << CPOL) | (1 << CPHA));
+ break;
+ case SPI_MODE_0: /* fallthrough */
+ default: break;
+ }
+
+ SPCR &= ~((1 << SPR1) | (1 << SPR0));
+ SPSR &= ~(1 << SPI2X);
+ switch (spip->config->clockrate) {
+ case SPI_SCK_FOSC_2:
+ SPSR |= (1 << SPI2X);
+ break;
+ case SPI_SCK_FOSC_8:
+ SPSR |= (1 << SPI2X);
+ SPCR |= (1 << SPR0);
+ break;
+ case SPI_SCK_FOSC_16:
+ SPCR |= (1 << SPR0);
+ break;
+ case SPI_SCK_FOSC_32:
+ SPSR |= (1 << SPI2X);
+ SPCR |= (1 << SPR1);
+ break;
+ case SPI_SCK_FOSC_64:
+ SPCR |= (1 << SPR1);
+ break;
+ case SPI_SCK_FOSC_128:
+ SPCR |= ((1 << SPR1) | (1 << SPR0));
+ break;
+ case SPI_SCK_FOSC_4: /* fallthrough */
+ default: break;
+ }
+
+ /* dummy reads before enabling interrupt */
+ dummy = SPSR;
+ dummy = SPDR;
+ (void) dummy; /* suppress warning about unused variable */
+ SPCR |= (1 << SPIE);
+ }
+#endif /* AVR_SPI_USE_SPI1 */
+ }
+}
+
+/**
+ * @brief Deactivates the SPI peripheral.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ *
+ * @notapi
+ */
+void spi_lld_stop(SPIDriver *spip) {
+
+ if (spip->state == SPI_READY) {
+ /* Resets the peripheral.*/
+
+ /* Disables the peripheral.*/
+#if AVR_SPI_USE_SPI1
+ if (&SPID1 == spip) {
+ SPCR &= ((1 << SPIE) | (1 << SPE));
+ spip->config->ssport->dir &= ~(1 << spip->config->sspad);
+ }
+/* Disable SPI clock using Power Reduction Register */
+#if defined(PRR0)
+ PRR0 |= (1 << PRSPI);
+#elif defined(PRR)
+ PRR |= (1 << PRSPI);
+#endif
+#endif /* AVR_SPI_USE_SPI1 */
+ }
+}
+
+/**
+ * @brief Asserts the slave select signal and prepares for transfers.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ *
+ * @notapi
+ */
+void spi_lld_select(SPIDriver *spip) {
+
+ /**
+ * NOTE: This should only be called in master mode.
+ */
+ spip->config->ssport->out &= ~(1 << spip->config->sspad);
+
+}
+
+/**
+ * @brief Deasserts the slave select signal.
+ * @details The previously selected peripheral is unselected.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ *
+ * @notapi
+ */
+void spi_lld_unselect(SPIDriver *spip) {
+
+ /**
+ * NOTE: This should only be called in master mode.
+ */
+ spip->config->ssport->out |= (1 << spip->config->sspad);
+
+}
+
+
+/**
+ * @brief Exchanges data on the SPI bus.
+ * @details This asynchronous function starts a simultaneous transmit/receive
+ * operation.
+ * @post At the end of the operation the configured callback is invoked.
+ * @note The buffers are organized as uint8_t arrays for data sizes below or
+ * equal to 8 bits else it is organized as uint16_t arrays.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ * @param[in] n number of words to be exchanged
+ * @param[in] txbuf the pointer to the transmit buffer
+ * @param[out] rxbuf the pointer to the receive buffer
+ *
+ * @notapi
+ */
+void spi_lld_exchange(SPIDriver *spip, size_t n, const void *txbuf, void *rxbuf) {
+
+ spip->txbuf = txbuf;
+ spip->rxbuf = rxbuf;
+ spip->exidx = 0;
+ spip->exbytes = n;
+ SPDR = (spip->txbuf ? spip->txbuf[0] : DUMMY_SPI_SEND_VALUE);
+}
+
+
+/**
+ * @brief Exchanges one frame using a polled wait.
+ * @details This synchronous function exchanges one frame using a polled
+ * synchronization method. This function is useful when exchanging
+ * small amount of data on high speed channels, usually in this
+ * situation is much more efficient just wait for completion using
+ * polling than suspending the thread waiting for an interrupt.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ * @param[in] frame the data frame to send over the SPI bus
+ * @return The received data frame from the SPI bus.
+ */
+#if AVR_SPI_USE_16BIT_POLLED_EXCHANGE
+uint16_t spi_lld_polled_exchange(SPIDriver *spip, uint16_t frame) {
+
+ uint16_t spdr = 0;
+ uint8_t dummy;
+
+ /* disable interrupt */
+ SPCR &= ~(1 << SPIE);
+
+ SPDR = frame >> 8;
+ while (!(SPSR & (1 << SPIF))) ;
+ spdr = SPDR << 8;
+
+ SPDR = frame & 0xFF;
+ while (!(SPSR & (1 << SPIF))) ;
+ spdr |= SPDR;
+
+ dummy = SPSR;
+ dummy = SPDR;
+ (void) dummy; /* suppress warning about unused variable */
+ SPCR |= (1 << SPIE);
+
+ return spdr;
+}
+#else /* AVR_SPI_USE_16BIT_POLLED_EXCHANGE */
+uint8_t spi_lld_polled_exchange(SPIDriver *spip, uint8_t frame) {
+
+ uint8_t spdr = 0;
+ uint8_t dummy;
+
+ /* disable interrupt */
+ SPCR &= ~(1 << SPIE);
+
+ SPDR = frame;
+ while (!(SPSR & (1 << SPIF))) ;
+ spdr = SPDR;
+
+ dummy = SPSR;
+ dummy = SPDR;
+ (void) dummy; /* suppress warning about unused variable */
+ SPCR |= (1 << SPIE);
+
+ return spdr;
+}
+#endif /* AVR_SPI_USE_16BIT_POLLED_EXCHANGE */
+
+#endif /* HAL_USE_SPI */
+
+/** @} */
diff --git a/os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.h b/os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.h
new file mode 100644
index 000000000..73d8ff856
--- /dev/null
+++ b/os/hal/ports/AVR/MEGA/LLD/SPIv1/hal_spi_lld.h
@@ -0,0 +1,257 @@
+/*
+ ChibiOS - Copyright (C) 2006..2016 Giovanni Di Sirio
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/**
+ * @file hal_spi_lld.h
+ * @brief AVR SPI subsystem low level driver header.
+ *
+ * @addtogroup SPI
+ * @{
+ */
+
+#ifndef HAL_SPI_LLD_H
+#define HAL_SPI_LLD_H
+
+#if HAL_USE_SPI || defined(__DOXYGEN__)
+
+/*===========================================================================*/
+/* Driver constants. */
+/*===========================================================================*/
+
+/** @brief SPI Mode (Polarity/Phase) */
+#define SPI_CPOL0_CPHA0 0
+#define SPI_CPOL0_CPHA1 1
+#define SPI_CPOL1_CPHA0 2
+#define SPI_CPOL1_CPHA1 3
+
+#define SPI_MODE_0 SPI_CPOL0_CPHA0
+#define SPI_MODE_1 SPI_CPOL0_CPHA1
+#define SPI_MODE_2 SPI_CPOL1_CPHA0
+#define SPI_MODE_3 SPI_CPOL1_CPHA1
+
+/** @brief Bit order */
+#define SPI_LSB_FIRST 0
+#define SPI_MSB_FIRST 1
+
+/** @brief SPI clock rate FOSC/x */
+#define SPI_SCK_FOSC_2 0
+#define SPI_SCK_FOSC_4 1
+#define SPI_SCK_FOSC_8 2
+#define SPI_SCK_FOSC_16 3
+#define SPI_SCK_FOSC_32 4
+#define SPI_SCK_FOSC_64 5
+#define SPI_SCK_FOSC_128 6
+
+/*===========================================================================*/
+/* Driver pre-compile time settings. */
+/*===========================================================================*/
+
+/**
+ * @name Configuration options
+ * @{
+ */
+/**
+ * @brief SPI driver enable switch.
+ * @details If set to @p TRUE the support for SPI1 is included.
+ */
+#if !defined(AVR_SPI_USE_SPI1) || defined(__DOXYGEN__)
+#define AVR_SPI_USE_SPI1 FALSE
+#endif
+/** @} */
+
+/*===========================================================================*/
+/* Derived constants and error checks. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver data structures and types. */
+/*===========================================================================*/
+
+/**
+ * @brief Type of a structure representing an SPI driver.
+ */
+typedef struct SPIDriver SPIDriver;
+
+/**
+ * @brief SPI notification callback type.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object triggering the
+ * callback
+ */
+typedef void (*spicallback_t)(SPIDriver *spip);
+
+/**
+ * @brief Driver configuration structure.
+ * @note Implementations may extend this structure to contain more,
+ * architecture dependent, fields.
+ */
+typedef struct {
+ /**
+ * @brief Port used of Slave Select
+ */
+ ioportid_t ssport;
+ /**
+ * @brief Pad used of Slave Select
+ */
+ uint8_t sspad;
+ /**
+ * @brief Polarity/Phase mode
+ */
+ uint8_t mode;
+ /**
+ * @brief Use MSB/LSB first?
+ */
+ uint8_t bitorder;
+ /**
+ * @brief Clock rate of the subsystem
+ */
+ uint8_t clockrate;
+ /**
+ * @brief Operation complete callback.
+ */
+ spicallback_t end_cb;
+ /* End of the mandatory fields.*/
+} SPIConfig;
+
+/**
+ * @brief Structure representing an SPI driver.
+ * @note Implementations may extend this structure to contain more,
+ * architecture dependent, fields.
+ */
+struct SPIDriver {
+ /**
+ * @brief Driver state.
+ */
+ spistate_t state;
+ /**
+ * @brief Current configuration data.
+ */
+ const SPIConfig *config;
+#if SPI_USE_WAIT || defined(__DOXYGEN__)
+ /**
+ * @brief Waiting thread.
+ */
+ thread_reference_t thread;
+#endif /* SPI_USE_WAIT */
+#if SPI_USE_MUTUAL_EXCLUSION || defined(__DOXYGEN__)
+ /**
+ * @brief Mutex protecting the bus.
+ */
+ mutex_t mutex;
+#endif /* SPI_USE_MUTUAL_EXCLUSION */
+#if defined(SPI_DRIVER_EXT_FIELDS)
+ SPI_DRIVER_EXT_FIELDS
+#endif
+ /* End of the mandatory fields.*/
+ /**
+ * @brief Pointer to the buffer with data to send.
+ */
+ const uint8_t *txbuf;
+ /**
+ * @brief Pointer to the buffer to store received data.
+ */
+ uint8_t *rxbuf;
+ /**
+ * @brief Number of bytes of data to exchange.
+ */
+ size_t exbytes;
+ /**
+ * @brief Current index in buffer when exchanging data.
+ */
+ size_t exidx;
+};
+
+/*===========================================================================*/
+/* Driver macros. */
+/*===========================================================================*/
+
+/**
+ * @brief Ignores data on the SPI bus.
+ * @details This asynchronous function starts the transmission of a series of
+ * idle words on the SPI bus and ignores the received data.
+ * @post At the end of the operation the configured callback is invoked.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ * @param[in] n number of words to be ignored
+ *
+ * @notapi
+ */
+#define spi_lld_ignore(spip, n) spi_lld_exchange(spip, n, NULL, NULL)
+
+/**
+ * @brief Sends data over the SPI bus.
+ * @details This asynchronous function starts a transmit operation.
+ * @post At the end of the operation the configured callback is invoked.
+ * @note The buffers are organized as uint8_t arrays for data sizes below or
+ * equal to 8 bits else it is organized as uint16_t arrays.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ * @param[in] n number of words to send
+ * @param[in] txbuf the pointer to the transmit buffer
+ *
+ * @notapi
+ */
+#define spi_lld_send(spip, n, txbuf) spi_lld_exchange(spip, n, txbuf, NULL)
+
+/**
+ * @brief Receives data from the SPI bus.
+ * @details This asynchronous function starts a receive operation.
+ * @post At the end of the operation the configured callback is invoked.
+ * @note The buffers are organized as uint8_t arrays for data sizes below or
+ * equal to 8 bits else it is organized as uint16_t arrays.
+ *
+ * @param[in] spip pointer to the @p SPIDriver object
+ * @param[in] n number of words to receive
+ * @param[out] rxbuf the pointer to the receive buffer
+ *
+ * @notapi
+ */
+#define spi_lld_receive(spip, n, rxbuf) spi_lld_exchange(spip, n, NULL, rxbuf)
+
+/*===========================================================================*/
+/* External declarations. */
+/*===========================================================================*/
+
+#if AVR_SPI_USE_SPI1 && !defined(__DOXYGEN__)
+extern SPIDriver SPID1;
+#endif
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+ void spi_lld_init(void);
+ void spi_lld_start(SPIDriver *spip);
+ void spi_lld_stop(SPIDriver *spip);
+ void spi_lld_select(SPIDriver *spip);
+ void spi_lld_unselect(SPIDriver *spip);
+ void spi_lld_exchange(SPIDriver *spip, size_t n,
+ const void *txbuf, void *rxbuf);
+
+#if AVR_SPI_USE_16BIT_POLLED_EXCHANGE
+ uint16_t spi_lld_polled_exchange(SPIDriver *spip, uint16_t frame);
+#else
+ uint8_t spi_lld_polled_exchange(SPIDriver *spip, uint8_t frame);
+#endif
+
+#ifdef __cplusplus
+}
+#endif
+
+#endif /* HAL_USE_SPI */
+
+#endif /* HAL_SPI_LLD_H */
+
+/** @} */