aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/e200
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2015-11-18 09:39:41 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2015-11-18 09:39:41 +0000
commitda4c0dbaa0a453af6b1903554ccff1df7b98825c (patch)
tree97e3d0d8ffec0947fc1195b353da4557ec30b6ee /os/common/ports/e200
parent5f2b47e17bbddd663b5237f3d235375f69f88d4f (diff)
downloadChibiOS-da4c0dbaa0a453af6b1903554ccff1df7b98825c.tar.gz
ChibiOS-da4c0dbaa0a453af6b1903554ccff1df7b98825c.tar.bz2
ChibiOS-da4c0dbaa0a453af6b1903554ccff1df7b98825c.zip
Improvements to the e200 RT port.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@8507 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/common/ports/e200')
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc560bcxx.mk11
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc560bxx.mk11
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc560dxx.mk11
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc560pxx.mk11
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc563mxx.mk11
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc564axx.mk11
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc56ecxx.mk11
-rw-r--r--os/common/ports/e200/compilers/GCC/mk/startup_spc56elxx.mk11
8 files changed, 88 insertions, 0 deletions
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc560bcxx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc560bcxx.mk
new file mode 100644
index 000000000..2e067b149
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc560bcxx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z0 SPC560BCxx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560BCxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560BCxx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc560bxx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc560bxx.mk
new file mode 100644
index 000000000..5cfc4a81e
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc560bxx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z0 SPC560Bxx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Bxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560Bxx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc560dxx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc560dxx.mk
new file mode 100644
index 000000000..4e8b633fd
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc560dxx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z0 SPC560Dxx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Dxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560Dxx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc560pxx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc560pxx.mk
new file mode 100644
index 000000000..72a62d787
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc560pxx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z0 SPC560Pxx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC560Pxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC560Pxx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc563mxx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc563mxx.mk
new file mode 100644
index 000000000..92af14e4c
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc563mxx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z3 SPC563Mxx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC563Mxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC563Mxx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc564axx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc564axx.mk
new file mode 100644
index 000000000..a903aa8ff
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc564axx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z4 SPC564Axx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC564Axx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC564Axx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc56ecxx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc56ecxx.mk
new file mode 100644
index 000000000..d2377e57f
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc56ecxx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z4 SPC56ECxx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC56ECxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC56ECxx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld
diff --git a/os/common/ports/e200/compilers/GCC/mk/startup_spc56elxx.mk b/os/common/ports/e200/compilers/GCC/mk/startup_spc56elxx.mk
new file mode 100644
index 000000000..40753b63f
--- /dev/null
+++ b/os/common/ports/e200/compilers/GCC/mk/startup_spc56elxx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS e200z4 SPC56ELxx startup files.
+STARTUPSRC =
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/e200/devices/SPC56ELxx/boot.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/vectors.s \
+ $(CHIBIOS)/os/common/ports/e200/compilers/GCC/crt0.s
+
+STARTUPINC = ${CHIBIOS}/os/common/ports/e200/compilers/GCC \
+ ${CHIBIOS}/os/common/ports/e200/devices/SPC56ELxx
+
+STARTUPLD = ${CHIBIOS}/os/common/ports/e200/compilers/GCC/ld