aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/e200
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-05-11 07:44:38 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-05-11 07:44:38 +0000
commit14b0f8138c8b8f4815bdb3a22e4da761ffb474a9 (patch)
tree74c697c53722d95ff737da03b5515e20023ec88d /os/common/ports/e200
parent643b4167f4cfc44984d4df4117c01f13a29d97a8 (diff)
downloadChibiOS-14b0f8138c8b8f4815bdb3a22e4da761ffb474a9.tar.gz
ChibiOS-14b0f8138c8b8f4815bdb3a22e4da761ffb474a9.tar.bz2
ChibiOS-14b0f8138c8b8f4815bdb3a22e4da761ffb474a9.zip
Fixed bug #501.
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@6925 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/common/ports/e200')
-rw-r--r--os/common/ports/e200/compilers/GCC/rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/os/common/ports/e200/compilers/GCC/rules.mk b/os/common/ports/e200/compilers/GCC/rules.mk
index 8ca82cac1..d42fd9773 100644
--- a/os/common/ports/e200/compilers/GCC/rules.mk
+++ b/os/common/ports/e200/compilers/GCC/rules.mk
@@ -98,6 +98,7 @@ CPPFLAGS = $(MCFLAGS) $(OPT) $(CPPOPT) $(CPPWARN) -Wa,-alms=$(LSTDIR)/$(notdir
LDFLAGS = $(MCFLAGS) $(OPT) -nostartfiles $(LLIBDIR) -Wl,-Map=$(BUILDDIR)/$(PROJECT).map,--cref,--no-warn-mismatch,--library-path=$(RULESPATH),$(LDOPT),--script=$(LDSCRIPT)
# Generate dependency information
+ASFLAGS += -MD -MP -MF .dep/$(@F).d
CFLAGS += -MD -MP -MF .dep/$(@F).d
CPPFLAGS += -MD -MP -MF .dep/$(@F).d