aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/ARMCMx
diff options
context:
space:
mode:
authorutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-08-03 23:45:32 +0000
committerutzig <utzig@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-08-03 23:45:32 +0000
commit6e81c34c57d58b541125015a41b274a3aed8c16a (patch)
tree15c677d0aaf662077a18b24698298dac578125e7 /os/common/ports/ARMCMx
parenta5ba02231106d70330e8b01dd60edba922e11f86 (diff)
downloadChibiOS-6e81c34c57d58b541125015a41b274a3aed8c16a.tar.gz
ChibiOS-6e81c34c57d58b541125015a41b274a3aed8c16a.tar.bz2
ChibiOS-6e81c34c57d58b541125015a41b274a3aed8c16a.zip
Fixed bug #521 - only create srec when there's a SREC var
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@7119 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/common/ports/ARMCMx')
-rw-r--r--os/common/ports/ARMCMx/compilers/GCC/rules.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/os/common/ports/ARMCMx/compilers/GCC/rules.mk b/os/common/ports/ARMCMx/compilers/GCC/rules.mk
index 11dd532f0..96c051692 100644
--- a/os/common/ports/ARMCMx/compilers/GCC/rules.mk
+++ b/os/common/ports/ARMCMx/compilers/GCC/rules.mk
@@ -64,9 +64,12 @@ endif
OUTFILES = $(BUILDDIR)/$(PROJECT).elf \
$(BUILDDIR)/$(PROJECT).hex \
$(BUILDDIR)/$(PROJECT).bin \
- $(BUILDDIR)/$(PROJECT).srec\
$(BUILDDIR)/$(PROJECT).dmp
+ifdef SREC
+OUTFILES += $(BUILDDIR)/$(PROJECT).srec
+endif
+
# Source files groups and paths
ifeq ($(USE_THUMB),yes)
TCSRC += $(CSRC)