aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/ARMCMx/compilers/GCC
diff options
context:
space:
mode:
authorgdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-02-06 10:37:50 +0000
committergdisirio <gdisirio@35acf78f-673a-0410-8e92-d51de3d6d3f4>2014-02-06 10:37:50 +0000
commitcf957f9d4a54d49f66d9af4ee7c7b4bb90660409 (patch)
treea7b63f1e94ec6a9d280a4ad9aadd1c20846aab5c /os/common/ports/ARMCMx/compilers/GCC
parent23f759922d415d9adaab70424b2c67ff0d9b7181 (diff)
downloadChibiOS-cf957f9d4a54d49f66d9af4ee7c7b4bb90660409.tar.gz
ChibiOS-cf957f9d4a54d49f66d9af4ee7c7b4bb90660409.tar.bz2
ChibiOS-cf957f9d4a54d49f66d9af4ee7c7b4bb90660409.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/branches/kernel_3_dev@6668 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/common/ports/ARMCMx/compilers/GCC')
-rw-r--r--os/common/ports/ARMCMx/compilers/GCC/rules.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/os/common/ports/ARMCMx/compilers/GCC/rules.mk b/os/common/ports/ARMCMx/compilers/GCC/rules.mk
index a9228e393..1d6def961 100644
--- a/os/common/ports/ARMCMx/compilers/GCC/rules.mk
+++ b/os/common/ports/ARMCMx/compilers/GCC/rules.mk
@@ -23,6 +23,9 @@ ifeq ($(USE_LTO),yes)
endif
# FPU-related options
+ifeq ($(USE_FPU),)
+ USE_FPU = no
+endif
ifneq ($(USE_FPU),no)
OPT += -mfloat-abi=$(USE_FPU) -mfpu=fpv4-sp-d16 -fsingle-precision-constant
DDEFS += -DCORTEX_USE_FPU=TRUE