aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/ARMCMx/compilers/GCC
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2015-10-24 09:32:03 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2015-10-24 09:32:03 +0000
commit2e098efd3d99a04221515b25b91856a1e730e70e (patch)
tree4c336872161e96a7036f5e5f6aa86c111b194031 /os/common/ports/ARMCMx/compilers/GCC
parent1f10e52dd5cc8f8539757e61e630265b92a4cd95 (diff)
downloadChibiOS-2e098efd3d99a04221515b25b91856a1e730e70e.tar.gz
ChibiOS-2e098efd3d99a04221515b25b91856a1e730e70e.tar.bz2
ChibiOS-2e098efd3d99a04221515b25b91856a1e730e70e.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@8389 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/common/ports/ARMCMx/compilers/GCC')
-rw-r--r--os/common/ports/ARMCMx/compilers/GCC/ld/STM32F207xG.ld54
-rw-r--r--os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f2xx.mk11
2 files changed, 65 insertions, 0 deletions
diff --git a/os/common/ports/ARMCMx/compilers/GCC/ld/STM32F207xG.ld b/os/common/ports/ARMCMx/compilers/GCC/ld/STM32F207xG.ld
new file mode 100644
index 000000000..644d358ab
--- /dev/null
+++ b/os/common/ports/ARMCMx/compilers/GCC/ld/STM32F207xG.ld
@@ -0,0 +1,54 @@
+/*
+ ChibiOS - Copyright (C) 2006..2015 Giovanni Di Sirio.
+
+ This file is part of ChibiOS.
+
+ ChibiOS is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/*
+ * STM32F207xG memory setup.
+ * Note: Use of ram1 and ram2 is mutually exclusive with use of ram0.
+ */
+MEMORY
+{
+ flash : org = 0x08000000, len = 1M
+ ram0 : org = 0x20000000, len = 128k /* SRAM1 + SRAM2 */
+ ram1 : org = 0x20000000, len = 112k /* SRAM1 */
+ ram2 : org = 0x2001C000, len = 16k /* SRAM2 */
+ ram3 : org = 0x00000000, len = 0
+ ram4 : org = 0x10000000, len = 64k /* CCM SRAM */
+ ram5 : org = 0x40024000, len = 4k /* BCKP SRAM */
+ ram6 : org = 0x00000000, len = 0
+ ram7 : org = 0x00000000, len = 0
+}
+
+/* RAM region to be used for Main stack. This stack accommodates the processing
+ of all exceptions and interrupts*/
+REGION_ALIAS("MAIN_STACK_RAM", ram0);
+
+/* RAM region to be used for the process stack. This is the stack used by
+ the main() function.*/
+REGION_ALIAS("PROCESS_STACK_RAM", ram0);
+
+/* RAM region to be used for data segment.*/
+REGION_ALIAS("DATA_RAM", ram0);
+
+/* RAM region to be used for BSS segment.*/
+REGION_ALIAS("BSS_RAM", ram0);
+
+/* RAM region to be used for the default heap.*/
+REGION_ALIAS("HEAP_RAM", ram0);
+
+INCLUDE rules.ld
diff --git a/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f2xx.mk b/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f2xx.mk
new file mode 100644
index 000000000..c1f08e57f
--- /dev/null
+++ b/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f2xx.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS generic STM32F2xx startup and CMSIS files.
+STARTUPSRC = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/crt1.c \
+ $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/vectors.c
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/crt0_v7m.s
+
+STARTUPINC = $(CHIBIOS)/os/common/ports/ARMCMx/devices/STM32F2xx \
+ $(CHIBIOS)/os/ext/CMSIS/include \
+ $(CHIBIOS)/os/ext/CMSIS/ST
+
+STARTUPLD = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/ld