aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/ARM/compilers/GCC
diff options
context:
space:
mode:
authorGiovanni Di Sirio <gdisirio@gmail.com>2015-04-03 09:51:52 +0000
committerGiovanni Di Sirio <gdisirio@gmail.com>2015-04-03 09:51:52 +0000
commite591fba1143eb14ab25e52f5947f6033fbdd334f (patch)
tree59f723bbcc0e60a14a2e3ff0b32b46fc7ffb6b7f /os/common/ports/ARM/compilers/GCC
parent030fe1d90878c6bcdfe771e4d933e859ca023698 (diff)
downloadChibiOS-e591fba1143eb14ab25e52f5947f6033fbdd334f.tar.gz
ChibiOS-e591fba1143eb14ab25e52f5947f6033fbdd334f.tar.bz2
ChibiOS-e591fba1143eb14ab25e52f5947f6033fbdd334f.zip
git-svn-id: svn://svn.code.sf.net/p/chibios/svn/trunk@7847 35acf78f-673a-0410-8e92-d51de3d6d3f4
Diffstat (limited to 'os/common/ports/ARM/compilers/GCC')
-rw-r--r--os/common/ports/ARM/compilers/GCC/crt0.s41
-rw-r--r--os/common/ports/ARM/compilers/GCC/crt1.c75
-rw-r--r--os/common/ports/ARM/compilers/GCC/mk/startup_lpc214x.mk2
3 files changed, 78 insertions, 40 deletions
diff --git a/os/common/ports/ARM/compilers/GCC/crt0.s b/os/common/ports/ARM/compilers/GCC/crt0.s
index 951fd4c78..dea01fb83 100644
--- a/os/common/ports/ARM/compilers/GCC/crt0.s
+++ b/os/common/ports/ARM/compilers/GCC/crt0.s
@@ -142,51 +142,14 @@ bssloop:
bx r0
.code 16
bl main
- ldr r1, =_main_exit_handler
+ ldr r1, =__default_exit
bx r1
.code 32
#else /* !defined(THUMB_NO_INTERWORKING) */
bl main
- b _main_exit_handler
+ b __default_exit
#endif /* !defined(THUMB_NO_INTERWORKING) */
-/*
- * Default main function exit handler.
- */
- .weak _main_exit_handler
-_main_exit_handler:
-.loop: b .loop
-
-/*
- * Default early initialization code. It is declared weak in order to be
- * replaced by the real initialization code.
- * Early initialization is performed just before reset before BSS and DATA
- * segments initialization.
- */
-#if defined(THUMB_NO_INTERWORKING)
- .thumb_func
- .code 16
-#endif
- .weak __early_init
-__early_init:
- bx lr
- .code 32
-
-/*
- * Default late initialization code. It is declared weak in order to be
- * replaced by the real initialization code.
- * Early initialization is performed just after reset before BSS and DATA
- * segments initialization.
- */
-#if defined(THUMB_NO_INTERWORKING)
- .thumb_func
- .code 16
-#endif
- .weak __late_init
-__late_init:
- bx lr
- .code 32
-
#endif /* !defined(__DOXYGEN__) */
/** @} */
diff --git a/os/common/ports/ARM/compilers/GCC/crt1.c b/os/common/ports/ARM/compilers/GCC/crt1.c
new file mode 100644
index 000000000..68e22b95a
--- /dev/null
+++ b/os/common/ports/ARM/compilers/GCC/crt1.c
@@ -0,0 +1,75 @@
+/*
+ ChibiOS - Copyright (C) 2006..2015 Giovanni Di Sirio.
+
+ This file is part of ChibiOS.
+
+ ChibiOS is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ ChibiOS is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+/**
+ * @file ARMCMx/compilers/GCC/crt1.c
+ * @brief Startup stub functions.
+ *
+ * @addtogroup ARMCMx_GCC_STARTUP
+ * @{
+ */
+
+#include <stdbool.h>
+
+/**
+ * @brief Early initialization.
+ * @details This hook is invoked immediately after the stack initialization
+ * and before the DATA and BSS segments initialization. The
+ * default behavior is to do nothing.
+ * @note This function is a weak symbol.
+ */
+#if !defined(__DOXYGEN__)
+__attribute__((weak))
+#endif
+/*lint -save -e9075 [8.4] All symbols are invoked from asm context.*/
+void __early_init(void) {}
+/*lint -restore*/
+
+/**
+ * @brief Late initialization.
+ * @details This hook is invoked after the DATA and BSS segments
+ * initialization and before any static constructor. The
+ * default behavior is to do nothing.
+ * @note This function is a weak symbol.
+ */
+#if !defined(__DOXYGEN__)
+__attribute__((weak))
+#endif
+/*lint -save -e9075 [8.4] All symbols are invoked from asm context.*/
+void __late_init(void) {}
+/*lint -restore*/
+
+/**
+ * @brief Default @p main() function exit handler.
+ * @details This handler is invoked or the @p main() function exit. The
+ * default behavior is to enter an infinite loop.
+ * @note This function is a weak symbol.
+ */
+#if !defined(__DOXYGEN__)
+__attribute__((noreturn, weak))
+#endif
+/*lint -save -e9075 [8.4] All symbols are invoked from asm context.*/
+void __default_exit(void) {
+/*lint -restore*/
+
+ while (true) {
+ }
+}
+
+/** @} */
diff --git a/os/common/ports/ARM/compilers/GCC/mk/startup_lpc214x.mk b/os/common/ports/ARM/compilers/GCC/mk/startup_lpc214x.mk
index 4927fd31d..4f1af1875 100644
--- a/os/common/ports/ARM/compilers/GCC/mk/startup_lpc214x.mk
+++ b/os/common/ports/ARM/compilers/GCC/mk/startup_lpc214x.mk
@@ -1,5 +1,5 @@
# List of the ChibiOS generic LPC214x file.
-STARTUPSRC =
+STARTUPSRC = $(CHIBIOS)/os/common/ports/ARM/compilers/GCC/crt1.c
STARTUPASM = $(CHIBIOS)/os/common/ports/ARM/compilers/GCC/vectors.s \
$(CHIBIOS)/os/common/ports/ARM/compilers/GCC/crt0.s