aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/TIVA/TM4C129x/platform.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/TIVA/TM4C129x/platform.mk')
-rw-r--r--os/hal/ports/TIVA/TM4C129x/platform.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/os/hal/ports/TIVA/TM4C129x/platform.mk b/os/hal/ports/TIVA/TM4C129x/platform.mk
new file mode 100644
index 0000000..83331e0
--- /dev/null
+++ b/os/hal/ports/TIVA/TM4C129x/platform.mk
@@ -0,0 +1,11 @@
+# List of all the TM4C129x platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/TM4C129x/hal_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/st_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pal_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/serial_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/TM4C129x \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD