aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/TIVA/TM4C123x/platform.mk
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/TIVA/TM4C123x/platform.mk')
-rw-r--r--os/hal/ports/TIVA/TM4C123x/platform.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/os/hal/ports/TIVA/TM4C123x/platform.mk b/os/hal/ports/TIVA/TM4C123x/platform.mk
index 3051cd3..0f54c5a 100644
--- a/os/hal/ports/TIVA/TM4C123x/platform.mk
+++ b/os/hal/ports/TIVA/TM4C123x/platform.mk
@@ -6,7 +6,9 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS}/community/os/hal/ports/TIVA/LLD/serial_lld.c \
${CHIBIOS}/community/os/hal/ports/TIVA/LLD/i2c_lld.c \
${CHIBIOS}/community/os/hal/ports/TIVA/LLD/gpt_lld.c \
- ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pwm_lld.c
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/pwm_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/TIVA/LLD/spi_lld.c \
+ ${CHISIOS}/community/os/hal/ports/TIVA/LLD/tiva_udma.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \