aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF5/NRF52832
diff options
context:
space:
mode:
Diffstat (limited to 'os/hal/ports/NRF5/NRF52832')
-rw-r--r--os/hal/ports/NRF5/NRF52832/hal_lld.c2
-rw-r--r--os/hal/ports/NRF5/NRF52832/hal_lld.h1
-rw-r--r--os/hal/ports/NRF5/NRF52832/nrf52_isr.c96
-rw-r--r--os/hal/ports/NRF5/NRF52832/nrf52_isr.h44
-rw-r--r--os/hal/ports/NRF5/NRF52832/platform.mk1
5 files changed, 144 insertions, 0 deletions
diff --git a/os/hal/ports/NRF5/NRF52832/hal_lld.c b/os/hal/ports/NRF5/NRF52832/hal_lld.c
index e63e57e..11307f8 100644
--- a/os/hal/ports/NRF5/NRF52832/hal_lld.c
+++ b/os/hal/ports/NRF5/NRF52832/hal_lld.c
@@ -87,6 +87,8 @@ void hal_lld_init(void)
NRF_CLOCK->TASKS_LFCLKSTART = 1;
while (NRF_CLOCK->EVENTS_LFCLKSTARTED == 0);
#endif
+
+ irqInit();
}
/**
diff --git a/os/hal/ports/NRF5/NRF52832/hal_lld.h b/os/hal/ports/NRF5/NRF52832/hal_lld.h
index a2a8cc3..0620b5f 100644
--- a/os/hal/ports/NRF5/NRF52832/hal_lld.h
+++ b/os/hal/ports/NRF5/NRF52832/hal_lld.h
@@ -115,6 +115,7 @@
#endif
#include "nvic.h"
+#include "nrf52_isr.h"
#ifdef __cplusplus
diff --git a/os/hal/ports/NRF5/NRF52832/nrf52_isr.c b/os/hal/ports/NRF5/NRF52832/nrf52_isr.c
new file mode 100644
index 0000000..7374f36
--- /dev/null
+++ b/os/hal/ports/NRF5/NRF52832/nrf52_isr.c
@@ -0,0 +1,96 @@
+/*
+ Copyright (C) 2018 Konstantin Oblaukhov
+ Copyright (C) 2015 Stephen Caudle
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/**
+ * @file NRF52832/nrf52_isr.c
+ * @brief NRF52832 ISR handler code.
+ *
+ * @addtogroup NRF52832_ISR
+ * @{
+ */
+
+#include "hal.h"
+
+/*===========================================================================*/
+/* Driver local definitions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver exported variables. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver local variables. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver local functions. */
+/*===========================================================================*/
+
+/*===========================================================================*/
+/* Driver interrupt handlers. */
+/*===========================================================================*/
+
+/**
+ * @brief GPIOTE interrupt handler.
+ *
+ * @isr
+ */
+OSAL_IRQ_HANDLER(Vector58) {
+
+ OSAL_IRQ_PROLOGUE();
+
+ for (int ch = 0; ch < NRF5_GPIOTE_NUM_CHANNELS; ch++)
+ {
+ if (NRF_GPIOTE->EVENTS_IN[ch])
+ {
+ NRF_GPIOTE->EVENTS_IN[ch] = 0;
+ _pal_isr_code(ch);
+ }
+ }
+
+ OSAL_IRQ_EPILOGUE();
+}
+
+/*===========================================================================*/
+/* Driver exported functions. */
+/*===========================================================================*/
+/**
+ * @brief Enables IRQ sources.
+ *
+ * @notapi
+ */
+void irqInit(void) {
+
+#if HAL_USE_PAL
+ nvicEnableVector(GPIOTE_IRQn, NRF5_IRQ_GPIOTE_PRIORITY);
+#endif
+}
+
+/**
+ * @brief Disables IRQ sources.
+ *
+ * @notapi
+ */
+void irqDeinit(void) {
+
+#if HAL_USE_PAL
+ nvicDisableVector(GPIOTE_IRQn);
+#endif
+}
+
+/** @} */
diff --git a/os/hal/ports/NRF5/NRF52832/nrf52_isr.h b/os/hal/ports/NRF5/NRF52832/nrf52_isr.h
new file mode 100644
index 0000000..b9f81d0
--- /dev/null
+++ b/os/hal/ports/NRF5/NRF52832/nrf52_isr.h
@@ -0,0 +1,44 @@
+/*
+ Copyright (C) 2018 Konstantin Oblaukhov
+ Copyright (C) 2015 Stephen Caudle
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/**
+ * @file NRF52832/nrf52_isr.h
+ * @brief NRF52832 ISR handler header.
+ *
+ * @addtogroup NRF52832_ISR
+ * @{
+ */
+
+#ifndef NRF52_ISR_H
+#define NRF52_ISR_H
+
+#if !defined(NRF5_IRQ_GPIOTE_PRIORITY) || defined(__DOXYGEN__)
+#define NRF5_IRQ_GPIOTE_PRIORITY 3
+#endif
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+ void irqInit(void);
+ void irqDeinit(void);
+#ifdef __cplusplus
+}
+#endif
+
+#endif /* NRF52_ISR_H */
+
+/** @} */
diff --git a/os/hal/ports/NRF5/NRF52832/platform.mk b/os/hal/ports/NRF5/NRF52832/platform.mk
index f1fcfe7..1e0a1af 100644
--- a/os/hal/ports/NRF5/NRF52832/platform.mk
+++ b/os/hal/ports/NRF5/NRF52832/platform.mk
@@ -1,5 +1,6 @@
PLATFORMSRC_CONTRIB := ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/NRF52832/hal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/NRF52832/nrf52_isr.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TIMERv1/hal_st_lld.c
PLATFORMINC_CONTRIB := ${CHIBIOS}/os/hal/ports/common/ARMCMx \