aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/TIVA/LLD/WDT
diff options
context:
space:
mode:
authorFabien Poussin <fabien.poussin@gmail.com>2017-04-23 01:52:07 +0200
committerGitHub <noreply@github.com>2017-04-23 01:52:07 +0200
commitfa9b5ac5ae2f6df6b0b861547260fddde3b37830 (patch)
tree35e296b08ae1a0503e0b846a1ab8ca9926444ca7 /os/hal/ports/TIVA/LLD/WDT
parentd72d463fee0c03931b2a462b687140935a582b44 (diff)
parent7f7665e8f207854a67026dd7865def9eafc9baea (diff)
downloadChibiOS-Contrib-fa9b5ac5ae2f6df6b0b861547260fddde3b37830.tar.gz
ChibiOS-Contrib-fa9b5ac5ae2f6df6b0b861547260fddde3b37830.tar.bz2
ChibiOS-Contrib-fa9b5ac5ae2f6df6b0b861547260fddde3b37830.zip
Merge pull request #115 from marcoveeneman/various_tiva_improvements
Various tiva improvements
Diffstat (limited to 'os/hal/ports/TIVA/LLD/WDT')
-rw-r--r--os/hal/ports/TIVA/LLD/WDT/driver.mk9
-rw-r--r--os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.c4
-rw-r--r--os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.h4
3 files changed, 13 insertions, 4 deletions
diff --git a/os/hal/ports/TIVA/LLD/WDT/driver.mk b/os/hal/ports/TIVA/LLD/WDT/driver.mk
new file mode 100644
index 0000000..867d0e6
--- /dev/null
+++ b/os/hal/ports/TIVA/LLD/WDT/driver.mk
@@ -0,0 +1,9 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
+PLATFORMSRC += $(CHIBIOS_CONTRIB)/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.c
+endif
+else
+PLATFORMSRC += $(CHIBIOS_CONTRIB)/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.c
+endif
+
+PLATFORMINC += $(CHIBIOS_CONTRIB)/os/hal/ports/TIVA/LLD/WDT
diff --git a/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.c b/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.c
index ddd01e0..705fce6 100644
--- a/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.c
+++ b/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.c
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -16,7 +16,7 @@
/**
- * @file TIVA/wdg_lld.c
+ * @file WDT/hal_wdg_lld.c
* @brief WDG Driver subsystem low level driver source.
*
* @addtogroup WDG
diff --git a/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.h b/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.h
index 77badb3..0f694c5 100644
--- a/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.h
+++ b/os/hal/ports/TIVA/LLD/WDT/hal_wdg_lld.h
@@ -1,5 +1,5 @@
/*
- Copyright (C) 2014..2016 Marco Veeneman
+ Copyright (C) 2014..2017 Marco Veeneman
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
@@ -16,7 +16,7 @@
/**
- * @file TIVA/wdg_lld.h
+ * @file WDT/hal_wdg_lld.h
* @brief WDG Driver subsystem low level driver header.
*
* @addtogroup WDG