aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F7xx
diff options
context:
space:
mode:
authorKonstantin Oblaukhov <oblaukhov.konstantin@gmail.com>2018-09-24 20:25:22 +0700
committerKonstantin Oblaukhov <oblaukhov.konstantin@gmail.com>2018-09-24 20:25:22 +0700
commitccfc9108293123edf1de4ca38dd7876d2d357206 (patch)
tree3589c0b2b7a86be2421dfe0f463d60fd6bf3358a /os/hal/ports/STM32/STM32F7xx
parent2c725099004628c1992e32390e3245928cd59eb4 (diff)
downloadChibiOS-Contrib-ccfc9108293123edf1de4ca38dd7876d2d357206.tar.gz
ChibiOS-Contrib-ccfc9108293123edf1de4ca38dd7876d2d357206.tar.bz2
ChibiOS-Contrib-ccfc9108293123edf1de4ca38dd7876d2d357206.zip
Update STM32 platform makefiles, add per-driver makefiles.
Diffstat (limited to 'os/hal/ports/STM32/STM32F7xx')
-rw-r--r--os/hal/ports/STM32/STM32F7xx/platform.mk22
1 files changed, 16 insertions, 6 deletions
diff --git a/os/hal/ports/STM32/STM32F7xx/platform.mk b/os/hal/ports/STM32/STM32F7xx/platform.mk
index 2f9392f..1c806a7 100644
--- a/os/hal/ports/STM32/STM32F7xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F7xx/platform.mk
@@ -1,9 +1,19 @@
include ${CHIBIOS}/os/hal/ports/STM32/STM32F7xx/platform.mk
-PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1/hal_fsmc.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1/hal_nand_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1/hal_fsmc_sram.c \
- ${CHIBIOS_CONTRIB}/os/hal/src/hal_fsmc_sdram.c
+ifeq ($(USE_SMART_BUILD),yes)
-PLATFORMINC += ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1 \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD
+# Configuration files directory
+ifeq ($(CONFDIR),)
+ CONFDIR = .
+endif
+
+HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h $(CONFDIR)/halconf_community.h | egrep -e "\#define"))
+
+else
+endif
+
+include ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1/driver.mk
+
+# Shared variables
+ALLCSRC += $(PLATFORMSRC_CONTRIB)
+ALLINC += $(PLATFORMINC_CONTRIB)