aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F4xx
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2014-10-18 16:34:12 +0300
committerbarthess <barthess@yandex.ru>2014-10-18 16:34:12 +0300
commit7355cbd461771f0d38cc2066f7a93b081ce38394 (patch)
treef34e8d6685247acd528e3d3d677a40261fa17313 /os/hal/ports/STM32/STM32F4xx
parent0214eb9bccecfee4598c8aa00b5af8c6f053ee31 (diff)
downloadChibiOS-Contrib-7355cbd461771f0d38cc2066f7a93b081ce38394.tar.gz
ChibiOS-Contrib-7355cbd461771f0d38cc2066f7a93b081ce38394.tar.bz2
ChibiOS-Contrib-7355cbd461771f0d38cc2066f7a93b081ce38394.zip
Added fsmc code
Diffstat (limited to 'os/hal/ports/STM32/STM32F4xx')
-rw-r--r--os/hal/ports/STM32/STM32F4xx/platform.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/os/hal/ports/STM32/STM32F4xx/platform.mk b/os/hal/ports/STM32/STM32F4xx/platform.mk
new file mode 100644
index 0000000..0fa3ce0
--- /dev/null
+++ b/os/hal/ports/STM32/STM32F4xx/platform.mk
@@ -0,0 +1,7 @@
+include ${CHIBIOS}/os/hal/ports/STM32/STM32F4xx/platform.mk
+
+PLATFORMSRC += ${CHIBIOS}/os/hal/ports/STM32/LLD/FSMCv1/fsmc.c \
+ ${CHIBIOS}/os/hal/ports/STM32/LLD/FSMCv1/nand_lld.c \
+ ${CHIBIOS}/os/hal/ports/STM32/LLD/FSMCv1/fsmc_sram.c
+
+PLATFORMINC += ${CHIBIOS}/os/hal/ports/STM32/LLD/FSMCv1