aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F4xx
diff options
context:
space:
mode:
authorTexZK <texzk@email.it>2015-06-24 21:24:45 +0200
committerTexZK <texzk@email.it>2015-06-24 21:24:45 +0200
commit542d79ef90862518ffcfb500679e293e5a89c864 (patch)
tree29e548064386cdd2ce063396d2331b6deafa33dd /os/hal/ports/STM32/STM32F4xx
parent57d8d8f5496922112f9af6251545d26ce5e915d6 (diff)
downloadChibiOS-Contrib-542d79ef90862518ffcfb500679e293e5a89c864.tar.gz
ChibiOS-Contrib-542d79ef90862518ffcfb500679e293e5a89c864.tar.bz2
ChibiOS-Contrib-542d79ef90862518ffcfb500679e293e5a89c864.zip
LTDC and DMA2D ported to ChibiOS/RT 3
+ LTDC and DMA2D peripheral drivers + LTDC and DMA2D demo project
Diffstat (limited to 'os/hal/ports/STM32/STM32F4xx')
-rw-r--r--os/hal/ports/STM32/STM32F4xx/platform.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/os/hal/ports/STM32/STM32F4xx/platform.mk b/os/hal/ports/STM32/STM32F4xx/platform.mk
index 598807e..022ff91 100644
--- a/os/hal/ports/STM32/STM32F4xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F4xx/platform.mk
@@ -1,11 +1,15 @@
include ${CHIBIOS}/os/hal/ports/STM32/STM32F4xx/platform.mk
-PLATFORMSRC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1/fsmc.c \
+PLATFORMSRC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/DMA2Dv1/stm32_dma2d.c \
+ ${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1/fsmc.c \
${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1/nand_lld.c \
${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1/fsmc_sram.c \
+ ${CHIBIOS}/community/os/hal/ports/STM32/LLD/LTDCv1/stm32_ltdc.c \
${CHIBIOS}/community/os/hal/ports/STM32/LLD/TIMv1/eicu_lld.c \
${CHIBIOS}/community/os/hal/src/fsmc_sdram.c
-PLATFORMINC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1 \
+PLATFORMINC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/DMA2Dv1 \
+ ${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1 \
+ ${CHIBIOS}/community/os/hal/ports/STM32/LLD/LTDCv1 \
${CHIBIOS}/community/os/hal/ports/STM32/LLD/TIMv1 \
${CHIBIOS}/community/os/hal/ports/STM32/LLD