aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F4xx
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-02-28 21:42:40 +0300
committerbarthess <barthess@yandex.ru>2015-02-28 21:42:40 +0300
commit4e7a5796b40e2d8d2779f31e4103c6934c537858 (patch)
tree12f46bf0665ef819718ede6b8f643a9a6d8fc54f /os/hal/ports/STM32/STM32F4xx
parent605fb84bcd73a41656c6c4261f5002be3bb69c6c (diff)
downloadChibiOS-Contrib-4e7a5796b40e2d8d2779f31e4103c6934c537858.tar.gz
ChibiOS-Contrib-4e7a5796b40e2d8d2779f31e4103c6934c537858.tar.bz2
ChibiOS-Contrib-4e7a5796b40e2d8d2779f31e4103c6934c537858.zip
Added EICU driver in HAL. Added STM32 backend for EICU.
Diffstat (limited to 'os/hal/ports/STM32/STM32F4xx')
-rw-r--r--os/hal/ports/STM32/STM32F4xx/platform.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/os/hal/ports/STM32/STM32F4xx/platform.mk b/os/hal/ports/STM32/STM32F4xx/platform.mk
index 2ede59d..cd25988 100644
--- a/os/hal/ports/STM32/STM32F4xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F4xx/platform.mk
@@ -3,6 +3,8 @@ include ${CHIBIOS}/os/hal/ports/STM32/STM32F4xx/platform.mk
PLATFORMSRC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1/fsmc.c \
${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1/nand_lld.c \
${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1/fsmc_sram.c \
+ ${CHIBIOS}/community/os/hal/ports/STM32/LLD/eicu_lld.c \
${CHIBIOS}/community/os/hal/src/fsmc_sdram.c
-PLATFORMINC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1
+PLATFORMINC += ${CHIBIOS}/community/os/hal/ports/STM32/LLD/FSMCv1 \
+ ${CHIBIOS}/community/os/hal/ports/STM32/LLD