aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F3xx
diff options
context:
space:
mode:
authorKonstantin Oblaukhov <oblaukhov.konstantin@gmail.com>2018-09-24 20:25:22 +0700
committerKonstantin Oblaukhov <oblaukhov.konstantin@gmail.com>2018-09-24 20:25:22 +0700
commitccfc9108293123edf1de4ca38dd7876d2d357206 (patch)
tree3589c0b2b7a86be2421dfe0f463d60fd6bf3358a /os/hal/ports/STM32/STM32F3xx
parent2c725099004628c1992e32390e3245928cd59eb4 (diff)
downloadChibiOS-Contrib-ccfc9108293123edf1de4ca38dd7876d2d357206.tar.gz
ChibiOS-Contrib-ccfc9108293123edf1de4ca38dd7876d2d357206.tar.bz2
ChibiOS-Contrib-ccfc9108293123edf1de4ca38dd7876d2d357206.zip
Update STM32 platform makefiles, add per-driver makefiles.
Diffstat (limited to 'os/hal/ports/STM32/STM32F3xx')
-rw-r--r--os/hal/ports/STM32/STM32F3xx/platform.mk29
1 files changed, 19 insertions, 10 deletions
diff --git a/os/hal/ports/STM32/STM32F3xx/platform.mk b/os/hal/ports/STM32/STM32F3xx/platform.mk
index 910fb1f..f41da95 100644
--- a/os/hal/ports/STM32/STM32F3xx/platform.mk
+++ b/os/hal/ports/STM32/STM32F3xx/platform.mk
@@ -1,12 +1,21 @@
include ${CHIBIOS}/os/hal/ports/STM32/STM32F3xx/platform.mk
-PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/CRCv1/hal_crc_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/TIMv1/hal_eicu_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/TIMv1/hal_timcap_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/TIMv1/hal_qei_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/COMPv1/hal_comp_lld.c \
-
-PLATFORMINC += ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/CRCv1 \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/TIMv1 \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/COMPv1 \
- ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD
+ifeq ($(USE_SMART_BUILD),yes)
+
+# Configuration files directory
+ifeq ($(CONFDIR),)
+ CONFDIR = .
+endif
+
+HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h $(CONFDIR)/halconf_community.h | egrep -e "\#define"))
+
+else
+endif
+
+include ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/CRCv1/driver.mk
+include ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/TIMv1/driver.mk
+include ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/COMPv1/driver.mk
+
+# Shared variables
+ALLCSRC += $(PLATFORMSRC_CONTRIB)
+ALLINC += $(PLATFORMINC_CONTRIB)