aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF51/NRF51822/platform.mk
diff options
context:
space:
mode:
authorUladzimir Pylinski <barthess@yandex.ru>2015-05-16 14:12:39 +0300
committerUladzimir Pylinski <barthess@yandex.ru>2015-05-16 14:12:39 +0300
commita6a7dec0da22f10ea1f814118072e1968ee191c0 (patch)
tree980e1c68e65b73880e4a5b51a1d776823b874195 /os/hal/ports/NRF51/NRF51822/platform.mk
parent67ccbf4da02f5be9b6cac213ee0ffdbf8797b7bf (diff)
parent2ba20d691dd398b3ef46d41d62edf20bcd97188b (diff)
downloadChibiOS-Contrib-a6a7dec0da22f10ea1f814118072e1968ee191c0.tar.gz
ChibiOS-Contrib-a6a7dec0da22f10ea1f814118072e1968ee191c0.tar.bz2
ChibiOS-Contrib-a6a7dec0da22f10ea1f814118072e1968ee191c0.zip
Merge pull request #7 from utzig/add-nrf51822-support
Add nrf51822 support
Diffstat (limited to 'os/hal/ports/NRF51/NRF51822/platform.mk')
-rw-r--r--os/hal/ports/NRF51/NRF51822/platform.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/os/hal/ports/NRF51/NRF51822/platform.mk b/os/hal/ports/NRF51/NRF51822/platform.mk
new file mode 100644
index 0000000..10aad23
--- /dev/null
+++ b/os/hal/ports/NRF51/NRF51822/platform.mk
@@ -0,0 +1,10 @@
+# List of all the NRF51x platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822/hal_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822/pal_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822/serial_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822/st_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822