aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF5/NRF52832/platform.mk
diff options
context:
space:
mode:
authorStephane D'Alu <sdalu@sdalu.com>2016-07-10 21:46:46 +0200
committerStephane D'Alu <sdalu@sdalu.com>2016-07-10 21:46:46 +0200
commit52107b2ccbf1b5ed29123d77d5cd3bc982fdee2e (patch)
treeb21afa77eeec8a26e2ccecdc41c246a4ac62fd27 /os/hal/ports/NRF5/NRF52832/platform.mk
parente5430a6f71a45f2a6b92aa11844d7df12ac466ce (diff)
downloadChibiOS-Contrib-52107b2ccbf1b5ed29123d77d5cd3bc982fdee2e.tar.gz
ChibiOS-Contrib-52107b2ccbf1b5ed29123d77d5cd3bc982fdee2e.tar.bz2
ChibiOS-Contrib-52107b2ccbf1b5ed29123d77d5cd3bc982fdee2e.zip
moved QEI to LLD
Diffstat (limited to 'os/hal/ports/NRF5/NRF52832/platform.mk')
-rw-r--r--os/hal/ports/NRF5/NRF52832/platform.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/hal/ports/NRF5/NRF52832/platform.mk b/os/hal/ports/NRF5/NRF52832/platform.mk
index 57ae88d..7ce922f 100644
--- a/os/hal/ports/NRF5/NRF52832/platform.mk
+++ b/os/hal/ports/NRF5/NRF52832/platform.mk
@@ -21,6 +21,9 @@ endif
ifneq ($(findstring HAL_USE_RNG TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_rng_lld.c
endif
+ifneq ($(findstring HAL_USE_QEI TRUE,$(HALCONF)),)
+PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_qei_lld.c
+endif
else
PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/NRF52832/hal_lld.c \
@@ -29,7 +32,8 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_st_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_gpt_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_wdg_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_rng_lld.c
+ ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_rng_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_qei_lld.c
endif
# Required include directories