aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF5/LLD/TWIMv1/driver.mk
diff options
context:
space:
mode:
authorFabien Poussin <fabien.poussin@gmail.com>2019-01-09 02:51:33 +0100
committerGitHub <noreply@github.com>2019-01-09 02:51:33 +0100
commite19ff53f02131d5a083bfda00d6481a7d7701b93 (patch)
treefb5e9103f986743d0fee5ce90cf2720753c4d0df /os/hal/ports/NRF5/LLD/TWIMv1/driver.mk
parentae22efae8bc0d6ac7a4f013c2a41641726344687 (diff)
parent2168085ac76c280880a0c2262a7e63fd0ce7c952 (diff)
downloadChibiOS-Contrib-e19ff53f02131d5a083bfda00d6481a7d7701b93.tar.gz
ChibiOS-Contrib-e19ff53f02131d5a083bfda00d6481a7d7701b93.tar.bz2
ChibiOS-Contrib-e19ff53f02131d5a083bfda00d6481a7d7701b93.zip
Merge pull request #178 from AndruPol/master
added NRF52 pwm, icu, i2c, radio esb drivers
Diffstat (limited to 'os/hal/ports/NRF5/LLD/TWIMv1/driver.mk')
-rw-r--r--os/hal/ports/NRF5/LLD/TWIMv1/driver.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/os/hal/ports/NRF5/LLD/TWIMv1/driver.mk b/os/hal/ports/NRF5/LLD/TWIMv1/driver.mk
new file mode 100644
index 0000000..43ad8e3
--- /dev/null
+++ b/os/hal/ports/NRF5/LLD/TWIMv1/driver.mk
@@ -0,0 +1,9 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_I2C TRUE,$(HALCONF)),)
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TWIMv1/hal_i2c_lld.c
+endif
+else
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TWIMv1/hal_i2c_lld.c
+endif
+
+PLATFORMINC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TWIMv1