aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF5/LLD/TIMERv1/driver.mk
diff options
context:
space:
mode:
authorFabien Poussin <fabien.poussin@gmail.com>2019-01-09 02:51:33 +0100
committerGitHub <noreply@github.com>2019-01-09 02:51:33 +0100
commite19ff53f02131d5a083bfda00d6481a7d7701b93 (patch)
treefb5e9103f986743d0fee5ce90cf2720753c4d0df /os/hal/ports/NRF5/LLD/TIMERv1/driver.mk
parentae22efae8bc0d6ac7a4f013c2a41641726344687 (diff)
parent2168085ac76c280880a0c2262a7e63fd0ce7c952 (diff)
downloadChibiOS-Contrib-e19ff53f02131d5a083bfda00d6481a7d7701b93.tar.gz
ChibiOS-Contrib-e19ff53f02131d5a083bfda00d6481a7d7701b93.tar.bz2
ChibiOS-Contrib-e19ff53f02131d5a083bfda00d6481a7d7701b93.zip
Merge pull request #178 from AndruPol/master
added NRF52 pwm, icu, i2c, radio esb drivers
Diffstat (limited to 'os/hal/ports/NRF5/LLD/TIMERv1/driver.mk')
-rw-r--r--os/hal/ports/NRF5/LLD/TIMERv1/driver.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/os/hal/ports/NRF5/LLD/TIMERv1/driver.mk b/os/hal/ports/NRF5/LLD/TIMERv1/driver.mk
index 6f3ce0e..333fe3c 100644
--- a/os/hal/ports/NRF5/LLD/TIMERv1/driver.mk
+++ b/os/hal/ports/NRF5/LLD/TIMERv1/driver.mk
@@ -2,8 +2,12 @@ ifeq ($(USE_SMART_BUILD),yes)
ifneq ($(findstring HAL_USE_GPT TRUE,$(HALCONF)),)
PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TIMERv1/hal_gpt_lld.c
endif
+ifneq ($(findstring HAL_USE_ICU TRUE,$(HALCONF)),)
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TIMERv1/hal_icu_lld.c
+endif
else
PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TIMERv1/hal_gpt_lld.c
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TIMERv1/hal_icu_lld.c
endif
PLATFORMINC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/TIMERv1