aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/KINETIS/MK66F18
diff options
context:
space:
mode:
authorMichael Walker <walkerstop@gmail.com>2018-05-03 18:41:14 -0700
committerMichael Walker <walkerstop@gmail.com>2018-05-07 07:45:08 -0700
commit619d45c0ffc02ca122f5ec7c34a1d6f82060fb7d (patch)
tree675aee7e3fb3446313cef31dbec44202de9bbbc3 /os/hal/ports/KINETIS/MK66F18
parentf4b640014d7b042e80dfaec520d3a02fb7220dfe (diff)
downloadChibiOS-Contrib-619d45c0ffc02ca122f5ec7c34a1d6f82060fb7d.tar.gz
ChibiOS-Contrib-619d45c0ffc02ca122f5ec7c34a1d6f82060fb7d.tar.bz2
ChibiOS-Contrib-619d45c0ffc02ca122f5ec7c34a1d6f82060fb7d.zip
Fix MK66F18 compilation for the following HALs: Serial, I2C, EXT, ADC, GPT, PWM, SPI
Diffstat (limited to 'os/hal/ports/KINETIS/MK66F18')
-rw-r--r--os/hal/ports/KINETIS/MK66F18/hal_lld.c4
-rw-r--r--os/hal/ports/KINETIS/MK66F18/platform.mk1
2 files changed, 3 insertions, 2 deletions
diff --git a/os/hal/ports/KINETIS/MK66F18/hal_lld.c b/os/hal/ports/KINETIS/MK66F18/hal_lld.c
index bb8991a..c9cd224 100644
--- a/os/hal/ports/KINETIS/MK66F18/hal_lld.c
+++ b/os/hal/ports/KINETIS/MK66F18/hal_lld.c
@@ -15,8 +15,8 @@
*/
/**
- * @file templates/hal_lld.c
- * @brief HAL Driver subsystem low level driver source template.
+ * @file MK66F18/hal_lld.c
+ * @brief Kinetis MK66F18 HAL Driver subsystem low level driver source template.
*
* @addtogroup HAL
* @{
diff --git a/os/hal/ports/KINETIS/MK66F18/platform.mk b/os/hal/ports/KINETIS/MK66F18/platform.mk
index d66a31d..0e6be12 100644
--- a/os/hal/ports/KINETIS/MK66F18/platform.mk
+++ b/os/hal/ports/KINETIS/MK66F18/platform.mk
@@ -8,6 +8,7 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_ext_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_adc_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_gpt_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_sdc_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18/hal_pwm_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_st_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_usb_lld.c