aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/KINETIS/MK66F18/platform.mk
diff options
context:
space:
mode:
authorMichael Walker <walkerstop@gmail.com>2018-04-30 16:34:26 -0700
committerMichael Walker <walkerstop@gmail.com>2018-04-30 16:34:26 -0700
commitb0a75810674d430ca104edda24800ff11073fdcb (patch)
tree6dcf4d56b1fc7d226979d4d1e78f47c9b5a80a91 /os/hal/ports/KINETIS/MK66F18/platform.mk
parent2de67e2f4a268eae072c5fd76a1b160124cee4f6 (diff)
downloadChibiOS-Contrib-b0a75810674d430ca104edda24800ff11073fdcb.tar.gz
ChibiOS-Contrib-b0a75810674d430ca104edda24800ff11073fdcb.tar.bz2
ChibiOS-Contrib-b0a75810674d430ca104edda24800ff11073fdcb.zip
Attempt at Teensy 3.6 support
Diffstat (limited to 'os/hal/ports/KINETIS/MK66F18/platform.mk')
-rw-r--r--os/hal/ports/KINETIS/MK66F18/platform.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/os/hal/ports/KINETIS/MK66F18/platform.mk b/os/hal/ports/KINETIS/MK66F18/platform.mk
new file mode 100644
index 0000000..d66a31d
--- /dev/null
+++ b/os/hal/ports/KINETIS/MK66F18/platform.mk
@@ -0,0 +1,18 @@
+# List of all platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18/hal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_pal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_serial_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18/hal_spi_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_i2c_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_ext_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_adc_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_gpt_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18/hal_pwm_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_st_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_usb_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18 \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD