aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/KINETIS/LLD/GPIOv1
diff options
context:
space:
mode:
authorKonstantin Oblaukhov <oblaukhov.konstantin@gmail.com>2018-10-07 18:34:01 +0700
committerKonstantin K. Oblaukhov <oblaukhov.konstantin@gmail.com>2018-11-20 09:53:30 +0700
commitd921781a45a5e2f57e56bf59872e1d2aec2fb71f (patch)
tree1c54eedb55550ccceb108cdaa84b47cd6869961f /os/hal/ports/KINETIS/LLD/GPIOv1
parentd200007a2985ed585a674bccb683b1bc953b2e36 (diff)
downloadChibiOS-Contrib-d921781a45a5e2f57e56bf59872e1d2aec2fb71f.tar.gz
ChibiOS-Contrib-d921781a45a5e2f57e56bf59872e1d2aec2fb71f.tar.bz2
ChibiOS-Contrib-d921781a45a5e2f57e56bf59872e1d2aec2fb71f.zip
KINETIS platform update for ChibiOS 18.2.x.
Diffstat (limited to 'os/hal/ports/KINETIS/LLD/GPIOv1')
-rw-r--r--os/hal/ports/KINETIS/LLD/GPIOv1/driver.mk9
-rw-r--r--os/hal/ports/KINETIS/LLD/GPIOv1/hal_pal_lld.h5
2 files changed, 14 insertions, 0 deletions
diff --git a/os/hal/ports/KINETIS/LLD/GPIOv1/driver.mk b/os/hal/ports/KINETIS/LLD/GPIOv1/driver.mk
new file mode 100644
index 0000000..1e9aca0
--- /dev/null
+++ b/os/hal/ports/KINETIS/LLD/GPIOv1/driver.mk
@@ -0,0 +1,9 @@
+ifeq ($(USE_SMART_BUILD),yes)
+ifneq ($(findstring HAL_USE_PAL TRUE,$(HALCONF)),)
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/GPIOv1/hal_pal_lld.c
+endif
+else
+PLATFORMSRC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/GPIOv1/hal_pal_lld.c
+endif
+
+PLATFORMINC_CONTRIB += ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/GPIOv1
diff --git a/os/hal/ports/KINETIS/LLD/GPIOv1/hal_pal_lld.h b/os/hal/ports/KINETIS/LLD/GPIOv1/hal_pal_lld.h
index 17125b1..376c0a6 100644
--- a/os/hal/ports/KINETIS/LLD/GPIOv1/hal_pal_lld.h
+++ b/os/hal/ports/KINETIS/LLD/GPIOv1/hal_pal_lld.h
@@ -83,6 +83,11 @@ typedef uint32_t ioline_t;
typedef GPIO_TypeDef *ioportid_t;
/**
+ * @brief Type of an pad identifier.
+ */
+typedef uint32_t iopadid_t;
+
+/**
* @brief Port Configuration.
* @details This structure stores the configuration parameters of all pads
* belonging to a port.