aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/KINETIS/K20x
diff options
context:
space:
mode:
authorFabio Utzig <utzig@utzig.org>2016-04-10 21:09:36 -0300
committerFabio Utzig <utzig@utzig.org>2016-04-10 21:09:36 -0300
commit5323be76402e0359570e81cdabd3cf929b8d41b2 (patch)
tree1c17a57e5f4ec142f0a3cc609ce5f60999d623d1 /os/hal/ports/KINETIS/K20x
parent99c3815a527585127b850f555078de4792ca7caf (diff)
parentb86af2c09feea9b50cb241c147a3881e55763a55 (diff)
downloadChibiOS-Contrib-5323be76402e0359570e81cdabd3cf929b8d41b2.tar.gz
ChibiOS-Contrib-5323be76402e0359570e81cdabd3cf929b8d41b2.tar.bz2
ChibiOS-Contrib-5323be76402e0359570e81cdabd3cf929b8d41b2.zip
Merge branch 'master' into fix-nrf51-port
Diffstat (limited to 'os/hal/ports/KINETIS/K20x')
-rw-r--r--os/hal/ports/KINETIS/K20x/hal_lld.h6
-rw-r--r--os/hal/ports/KINETIS/K20x/hal_pwm_lld.c (renamed from os/hal/ports/KINETIS/K20x/pwm_lld.c)0
-rw-r--r--os/hal/ports/KINETIS/K20x/hal_pwm_lld.h (renamed from os/hal/ports/KINETIS/K20x/pwm_lld.h)6
-rw-r--r--os/hal/ports/KINETIS/K20x/hal_spi_lld.c (renamed from os/hal/ports/KINETIS/K20x/spi_lld.c)0
-rw-r--r--os/hal/ports/KINETIS/K20x/hal_spi_lld.h (renamed from os/hal/ports/KINETIS/K20x/spi_lld.h)6
-rw-r--r--os/hal/ports/KINETIS/K20x/kinetis_registry.h6
-rw-r--r--os/hal/ports/KINETIS/K20x/platform.mk20
7 files changed, 22 insertions, 22 deletions
diff --git a/os/hal/ports/KINETIS/K20x/hal_lld.h b/os/hal/ports/KINETIS/K20x/hal_lld.h
index 31364cf..b7f6b46 100644
--- a/os/hal/ports/KINETIS/K20x/hal_lld.h
+++ b/os/hal/ports/KINETIS/K20x/hal_lld.h
@@ -22,8 +22,8 @@
* @{
*/
-#ifndef _HAL_LLD_H_
-#define _HAL_LLD_H_
+#ifndef HAL_LLD_H_
+#define HAL_LLD_H_
#include "kinetis_registry.h"
@@ -297,6 +297,6 @@ extern "C" {
}
#endif
-#endif /* _HAL_LLD_H_ */
+#endif /* HAL_LLD_H_ */
/** @} */
diff --git a/os/hal/ports/KINETIS/K20x/pwm_lld.c b/os/hal/ports/KINETIS/K20x/hal_pwm_lld.c
index f5a8d96..f5a8d96 100644
--- a/os/hal/ports/KINETIS/K20x/pwm_lld.c
+++ b/os/hal/ports/KINETIS/K20x/hal_pwm_lld.c
diff --git a/os/hal/ports/KINETIS/K20x/pwm_lld.h b/os/hal/ports/KINETIS/K20x/hal_pwm_lld.h
index 176e8a8..ccc100f 100644
--- a/os/hal/ports/KINETIS/K20x/pwm_lld.h
+++ b/os/hal/ports/KINETIS/K20x/hal_pwm_lld.h
@@ -22,8 +22,8 @@
* @{
*/
-#ifndef _PWM_LLD_H_
-#define _PWM_LLD_H_
+#ifndef HAL_PWM_LLD_H_
+#define HAL_PWM_LLD_H_
#if HAL_USE_PWM || defined(__DOXYGEN__)
@@ -265,6 +265,6 @@ extern "C" {
#endif /* HAL_USE_PWM */
-#endif /* _PWM_LLD_H_ */
+#endif /* HAL_PWM_LLD_H_ */
/** @} */
diff --git a/os/hal/ports/KINETIS/K20x/spi_lld.c b/os/hal/ports/KINETIS/K20x/hal_spi_lld.c
index 29ab4e8..29ab4e8 100644
--- a/os/hal/ports/KINETIS/K20x/spi_lld.c
+++ b/os/hal/ports/KINETIS/K20x/hal_spi_lld.c
diff --git a/os/hal/ports/KINETIS/K20x/spi_lld.h b/os/hal/ports/KINETIS/K20x/hal_spi_lld.h
index a1f2a99..0cf108e 100644
--- a/os/hal/ports/KINETIS/K20x/spi_lld.h
+++ b/os/hal/ports/KINETIS/K20x/hal_spi_lld.h
@@ -22,8 +22,8 @@
* @{
*/
-#ifndef _SPI_LLD_H_
-#define _SPI_LLD_H_
+#ifndef HAL_SPI_LLD_H_
+#define HAL_SPI_LLD_H_
#if HAL_USE_SPI || defined(__DOXYGEN__)
@@ -256,6 +256,6 @@ extern "C" {
#endif /* HAL_USE_SPI */
-#endif /* _SPI_LLD_H_ */
+#endif /* HAL_SPI_LLD_H_ */
/** @} */
diff --git a/os/hal/ports/KINETIS/K20x/kinetis_registry.h b/os/hal/ports/KINETIS/K20x/kinetis_registry.h
index 4c70e84..d2eea6f 100644
--- a/os/hal/ports/KINETIS/K20x/kinetis_registry.h
+++ b/os/hal/ports/KINETIS/K20x/kinetis_registry.h
@@ -23,8 +23,8 @@
* @{
*/
-#ifndef _KINETIS_REGISTRY_H_
-#define _KINETIS_REGISTRY_H_
+#ifndef KINETIS_REGISTRY_H_
+#define KINETIS_REGISTRY_H_
#if !defined(K20x) || defined(__DOXYGEN__)
#define K20x
@@ -253,6 +253,6 @@
/** @} */
-#endif /* _KINETIS_REGISTRY_H_ */
+#endif /* KINETIS_REGISTRY_H_ */
/** @} */
diff --git a/os/hal/ports/KINETIS/K20x/platform.mk b/os/hal/ports/KINETIS/K20x/platform.mk
index baa90a2..beee336 100644
--- a/os/hal/ports/KINETIS/K20x/platform.mk
+++ b/os/hal/ports/KINETIS/K20x/platform.mk
@@ -1,16 +1,16 @@
# List of all platform files.
PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/K20x/hal_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/pal_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/serial_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/K20x/spi_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/i2c_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/ext_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/adc_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/gpt_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/K20x/pwm_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/st_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/usb_lld.c
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_pal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_serial_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/K20x/hal_spi_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_i2c_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_ext_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_adc_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_gpt_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/K20x/hal_pwm_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_st_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_usb_lld.c
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \