From f120a607293fcb09054ba34dc0491e8c31561375 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jow@openwrt.org>
Date: Sun, 12 Aug 2012 12:34:30 +0000
Subject: [tools] use HOST_STATIC_LINKING instead of hardcoding -static

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33140 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 tools/upx/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'tools/upx')

diff --git a/tools/upx/Makefile b/tools/upx/Makefile
index 339c611154..3e76232012 100644
--- a/tools/upx/Makefile
+++ b/tools/upx/Makefile
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
 define Host/Compile
 	rm -f $(HOST_BUILD_DIR)/src/.depend
 	$(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
-		CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) -static"
+		CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) $(HOST_STATIC_LINKING)"
 endef
 
 define Host/Install
-- 
cgit v1.2.3