From d8b7d994782158332a5fef4d82c7cebf1a12935b Mon Sep 17 00:00:00 2001
From: Luka Perkov <luka@openwrt.org>
Date: Wed, 20 Nov 2013 22:09:11 +0000
Subject: pkg-config: fix occasional install problem

Signed-off-by: Luka Perkov <luka@openwrt.org>

SVN-Revision: 38886
---
 tools/pkg-config/Makefile                          |  2 +-
 .../patches/001-fix-package-rebuild.patch          | 22 ++++++++++++++++++++++
 2 files changed, 23 insertions(+), 1 deletion(-)
 create mode 100644 tools/pkg-config/patches/001-fix-package-rebuild.patch

(limited to 'tools/pkg-config')

diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index 6bd53f8610..0edc807e9d 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
diff --git a/tools/pkg-config/patches/001-fix-package-rebuild.patch b/tools/pkg-config/patches/001-fix-package-rebuild.patch
new file mode 100644
index 0000000000..54f549c076
--- /dev/null
+++ b/tools/pkg-config/patches/001-fix-package-rebuild.patch
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -39,7 +39,7 @@
+ if HOST_TOOL
+ host_tool = $(host)-pkg-config$(EXEEXT)
+ install-exec-hook:
+-	cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++	cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ uninstall-hook:
+ 	cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
+ endif
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1093,7 +1093,7 @@
+ 	uninstall-man1
+ 
+ @HOST_TOOL_TRUE@install-exec-hook:
+-@HOST_TOOL_TRUE@	cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++@HOST_TOOL_TRUE@	cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ @HOST_TOOL_TRUE@uninstall-hook:
+ @HOST_TOOL_TRUE@	cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
+ 
-- 
cgit v1.2.3