From d748bad85e8d4263c2d014e8121629ce4a43314b Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Wed, 21 Jan 2009 11:58:17 +0000
Subject: [toolchain] add support for gcc v4.3.1 & v4.3.2 (closes: #3479),
 thanks to Luigi Mantellini!

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14131 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 tools/mpfr/Makefile | 41 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 41 insertions(+)
 create mode 100644 tools/mpfr/Makefile

(limited to 'tools/mpfr')

diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
new file mode 100644
index 0000000000..84dc9ec29f
--- /dev/null
+++ b/tools/mpfr/Makefile
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mpfr
+PKG_VERSION:=2.3.2
+
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-current/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+	(cd $(PKG_BUILD_DIR); \
+	./configure \
+	  --prefix=$(STAGING_DIR_HOST) \
+	  --build=$(GNU_HOST_NAME) \
+	  --enable-static \
+	  --disable-shared \
+	  --with-gmp=$(STAGING_DIR_HOST) \
+	);
+endef
+
+define Build/Compile
+	make -C $(PKG_BUILD_DIR) all
+endef
+
+define Build/Install
+	make -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+	rm -rf $(PKG_BUILD_DIR)
+endef
+
+$(eval $(call HostBuild))
-- 
cgit v1.2.3