From fd6e548d42075b6bea023b92544c37a03e36f4c8 Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Fri, 2 Oct 2009 00:18:16 +0000
Subject: uClibc: remove absolute path linking to host libraries in
 libpthread.so (closes: #5601)

SVN-Revision: 17814
---
 toolchain/uClibc/Makefile | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

(limited to 'toolchain/uClibc')

diff --git a/toolchain/uClibc/Makefile b/toolchain/uClibc/Makefile
index 7206df2720..1d18bffb49 100644
--- a/toolchain/uClibc/Makefile
+++ b/toolchain/uClibc/Makefile
@@ -103,15 +103,15 @@ define Host/Compile
 	$(UCLIBC_MAKE) PREFIX="$(TOOLCHAIN_DIR)/" install_runtime install_dev
 	ln -sf ../../lib/libc.so.0 $(TOOLCHAIN_DIR)/usr/lib/libc.so
 	$(CP) $(HOST_BUILD_DIR)/libc/libc_so.a $(TOOLCHAIN_DIR)/usr/lib/
-#	( cd $(TOOLCHAIN_DIR) ; \
-#		for d in lib usr/lib ; do \
-#		  for f in libc.so libpthread.so libgcc_s.so ; do \
-#		    if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
-#		      $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
-#		    fi \
-#		  done \
-#		done \
-#	)
+	( cd $(TOOLCHAIN_DIR) ; \
+		for d in lib usr/lib ; do \
+		  for f in libc.so libpthread.so libgcc_s.so ; do \
+		    if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
+		      $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
+		    fi \
+		  done \
+		done \
+	)
 endef
 
 define Host/Install
-- 
cgit v1.2.3