From 10d11328effd162340acc9b30b943dc98bf80f18 Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Sat, 6 Mar 2010 17:10:45 +0000
Subject: gcc: only enable/disable TLS support in final stage (closes: #6788)

SVN-Revision: 20018
---
 toolchain/gcc/Makefile | 13 ++++++++-----
 1 file changed, 8 insertions(+), 5 deletions(-)

(limited to 'toolchain/gcc')

diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index 9c820f2fec..9536cc245b 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -116,11 +116,6 @@ else
 		--disable-libssp
 endif
 
-ifeq ($(CONFIG_TLS_SUPPORT),)
-  GCC_CONFIGURE+= \
-		--disable-tls
-endif
-
 ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
   GCC_CONFIGURE+= \
 		--enable-biarch \
@@ -159,6 +154,14 @@ GCC_CONFIGURE_STAGE2:= \
 		--enable-threads \
 		--with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifneq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE_STAGE2+= \
+		--enable-tls
+else
+  GCC_CONFIGURE_STAGE2+= \
+		--disable-tls
+endif
+
 ifdef CONFIG_powerpc
   TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
 endif
-- 
cgit v1.2.3