From a3b32c41dff39c83e27a88e0ff9c21f5c0c79c93 Mon Sep 17 00:00:00 2001
From: Imre Kaloz <kaloz@openwrt.org>
Date: Mon, 4 May 2009 10:37:48 +0000
Subject: refresh generic 2.6.28 patches

SVN-Revision: 15578
---
 .../generic-2.6/patches-2.6.28/100-netfilter_layer7_2.21.patch | 10 +++++-----
 .../patches-2.6.28/101-netfilter_layer7_pktmatch.patch         | 10 +++++-----
 .../linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch   |  2 +-
 target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch   |  2 +-
 4 files changed, 12 insertions(+), 12 deletions(-)

(limited to 'target/linux')

diff --git a/target/linux/generic-2.6/patches-2.6.28/100-netfilter_layer7_2.21.patch b/target/linux/generic-2.6/patches-2.6.28/100-netfilter_layer7_2.21.patch
index 59c3f8b47d..57f1b02742 100644
--- a/target/linux/generic-2.6/patches-2.6.28/100-netfilter_layer7_2.21.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/100-netfilter_layer7_2.21.patch
@@ -16,7 +16,7 @@
 +#endif /* _XT_LAYER7_H */
 --- a/include/net/netfilter/nf_conntrack.h
 +++ b/include/net/netfilter/nf_conntrack.h
-@@ -118,6 +118,22 @@
+@@ -118,6 +118,22 @@ struct nf_conn
  	u_int32_t secmark;
  #endif
  
@@ -41,7 +41,7 @@
  
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -795,6 +795,27 @@
+@@ -795,6 +795,27 @@ config NETFILTER_XT_MATCH_STATE
  
  	  To compile it as a module, choose M here.  If unsure, say N.
  
@@ -71,7 +71,7 @@
  	depends on NETFILTER_ADVANCED
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -84,6 +84,7 @@
+@@ -84,6 +84,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT) 
  obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
@@ -81,7 +81,7 @@
  obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -201,6 +201,14 @@
+@@ -201,6 +201,14 @@ destroy_conntrack(struct nf_conntrack *n
  	 * too. */
  	nf_ct_remove_expectations(ct);
  
@@ -98,7 +98,7 @@
  		BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -165,6 +165,12 @@
+@@ -165,6 +165,12 @@ static int ct_seq_show(struct seq_file *
  		return -ENOSPC;
  #endif
  
diff --git a/target/linux/generic-2.6/patches-2.6.28/101-netfilter_layer7_pktmatch.patch b/target/linux/generic-2.6/patches-2.6.28/101-netfilter_layer7_pktmatch.patch
index 4931b1bdb7..f65e301fd1 100644
--- a/target/linux/generic-2.6/patches-2.6.28/101-netfilter_layer7_pktmatch.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/101-netfilter_layer7_pktmatch.patch
@@ -1,6 +1,6 @@
 --- a/include/linux/netfilter/xt_layer7.h
 +++ b/include/linux/netfilter/xt_layer7.h
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,7 @@ struct xt_layer7_info {
      char protocol[MAX_PROTOCOL_LEN];
      char pattern[MAX_PATTERN_LEN];
      u_int8_t invert;
@@ -10,7 +10,7 @@
  #endif /* _XT_LAYER7_H */
 --- a/net/netfilter/xt_layer7.c
 +++ b/net/netfilter/xt_layer7.c
-@@ -314,33 +314,35 @@
+@@ -314,33 +314,35 @@ static int match_no_append(struct nf_con
  }
  
  /* add the new app data to the conntrack.  Return number of bytes added. */
@@ -60,7 +60,7 @@
  
  	return length;
  }
-@@ -438,7 +440,7 @@
+@@ -438,7 +440,7 @@ match(const struct sk_buff *skbin,
  
  	enum ip_conntrack_info master_ctinfo, ctinfo;
  	struct nf_conn *master_conntrack, *conntrack;
@@ -69,7 +69,7 @@
  	unsigned int pattern_result, appdatalen;
  	regexp * comppattern;
  
-@@ -466,8 +468,8 @@
+@@ -466,8 +468,8 @@ match(const struct sk_buff *skbin,
  		master_conntrack = master_ct(master_conntrack);
  
  	/* if we've classified it or seen too many packets */
@@ -80,7 +80,7 @@
  
  		pattern_result = match_no_append(conntrack, master_conntrack, 
  						 ctinfo, master_ctinfo, info);
-@@ -500,6 +502,25 @@
+@@ -500,6 +502,25 @@ match(const struct sk_buff *skbin,
  	/* the return value gets checked later, when we're ready to use it */
  	comppattern = compile_and_cache(info->pattern, info->protocol);
  
diff --git a/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch b/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
index ca25aeda99..9d9ae5023e 100644
--- a/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
@@ -27,7 +27,7 @@
  				  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
  		.napi_event	= RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
  		.features	= RTL_FEATURE_MSI
-@@ -3554,10 +3554,12 @@ static irqreturn_t rtl8169_interrupt(int
+@@ -3555,10 +3555,12 @@ static irqreturn_t rtl8169_interrupt(int
  		goto out;
  	}
  
diff --git a/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch b/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
index 8168742eba..023bf295e7 100644
--- a/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
+++ b/target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch
@@ -67,7 +67,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -5015,6 +5015,7 @@ int can_nice(const struct task_struct *p
+@@ -5064,6 +5064,7 @@ int can_nice(const struct task_struct *p
  	return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
  		capable(CAP_SYS_NICE));
  }
-- 
cgit v1.2.3