From 443072fda7471d568e40c60c0697e342c9760faa Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Wed, 25 Sep 2013 14:38:56 +0000
Subject: kernel/3.10: refresh patches

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

SVN-Revision: 38178
---
 .../patches-3.10/405-mtd-add-more-helper-functions.patch       |  2 +-
 .../patches-3.10/411-mtd-partial_eraseblock_write.patch        | 10 +++++-----
 .../patches-3.10/412-mtd-partial_eraseblock_unlock.patch       |  2 +-
 .../patches-3.10/430-mtd-add-myloader-partition-parser.patch   |  4 ++--
 4 files changed, 9 insertions(+), 9 deletions(-)

(limited to 'target/linux')

diff --git a/target/linux/generic/patches-3.10/405-mtd-add-more-helper-functions.patch b/target/linux/generic/patches-3.10/405-mtd-add-more-helper-functions.patch
index 4e54b1bf9d..97ad2db87e 100644
--- a/target/linux/generic/patches-3.10/405-mtd-add-more-helper-functions.patch
+++ b/target/linux/generic/patches-3.10/405-mtd-add-more-helper-functions.patch
@@ -18,7 +18,7 @@
  	}
  	if (slave->offset == MTDPART_OFS_RETAIN) {
  		slave->offset = cur_offset;
-@@ -996,6 +994,24 @@ int mtd_is_partition(const struct mtd_in
+@@ -995,6 +993,24 @@ int mtd_is_partition(const struct mtd_in
  }
  EXPORT_SYMBOL_GPL(mtd_is_partition);
  
diff --git a/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch b/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch
index 07db137061..560096f854 100644
--- a/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch
+++ b/target/linux/generic/patches-3.10/411-mtd-partial_eraseblock_write.patch
@@ -1,15 +1,15 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -35,6 +35,8 @@
- 
+@@ -36,6 +36,8 @@
  #include "mtdcore.h"
+ #include "mtdsplit.h"
  
 +#define MTD_ERASE_PARTIAL	0x8000 /* partition only covers parts of an erase block */
 +
  /* Our partition linked list */
  static LIST_HEAD(mtd_partitions);
  static DEFINE_MUTEX(mtd_partitions_mutex);
-@@ -231,13 +233,60 @@ static int part_erase(struct mtd_info *m
+@@ -232,13 +234,60 @@ static int part_erase(struct mtd_info *m
  	struct mtd_part *part = PART(mtd);
  	int ret;
  
@@ -70,7 +70,7 @@
  	return ret;
  }
  
-@@ -245,7 +294,25 @@ void mtd_erase_callback(struct erase_inf
+@@ -246,7 +295,25 @@ void mtd_erase_callback(struct erase_inf
  {
  	if (instr->mtd->_erase == part_erase) {
  		struct mtd_part *part = PART(instr->mtd);
@@ -96,7 +96,7 @@
  		if (instr->fail_addr != MTD_FAIL_ADDR_UNKNOWN)
  			instr->fail_addr -= part->offset;
  		instr->addr -= part->offset;
-@@ -505,18 +572,24 @@ static struct mtd_part *allocate_partiti
+@@ -504,18 +571,24 @@ static struct mtd_part *allocate_partiti
  	if ((slave->mtd.flags & MTD_WRITEABLE) &&
  	    mtd_mod_by_eb(slave->offset, &slave->mtd)) {
  		/* Doesn't start on a boundary of major erase size */
diff --git a/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch b/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch
index 134f65715e..87c8257fe1 100644
--- a/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch
+++ b/target/linux/generic/patches-3.10/412-mtd-partial_eraseblock_unlock.patch
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
+@@ -332,7 +332,14 @@ static int part_lock(struct mtd_info *mt
  static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
  {
  	struct mtd_part *part = PART(mtd);
diff --git a/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch
index bca00230ae..47c2fd06e7 100644
--- a/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch
+++ b/target/linux/generic/patches-3.10/430-mtd-add-myloader-partition-parser.patch
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -181,6 +181,22 @@ config MTD_BCM47XX_PARTS
+@@ -208,6 +208,22 @@ config MTD_BCM47XX_PARTS
  	  This provides partitions parser for devices based on BCM47xx
  	  boards.
  
@@ -25,7 +25,7 @@
  config MTD_BLKDEVS
 --- a/drivers/mtd/Makefile
 +++ b/drivers/mtd/Makefile
-@@ -13,6 +13,7 @@ obj-$(CONFIG_MTD_AFS_PARTS)	+= afs.o
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MTD_AFS_PARTS)	+= afs.o
  obj-$(CONFIG_MTD_AR7_PARTS)	+= ar7part.o
  obj-$(CONFIG_MTD_BCM63XX_PARTS)	+= bcm63xxpart.o
  obj-$(CONFIG_MTD_BCM47XX_PARTS)	+= bcm47xxpart.o
-- 
cgit v1.2.3