From 74d00a8c3849c1340efd713eb94b786e304c201f Mon Sep 17 00:00:00 2001
From: John Crispin <john@phrozen.org>
Date: Sun, 25 Dec 2016 20:11:34 +0100
Subject: kernel: split patches folder up into backport, pending and hack
 folders

* properly format/comment all patches
* merge debloat patches
* merge Kconfig patches
* merge swconfig patches
* merge hotplug patches
* drop 200-fix_localversion.patch - upstream
* drop 222-arm_zimage_none.patch - unused
* drop 252-mv_cesa_depends.patch - no longer required
* drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused
* drop 661-fq_codel_keep_dropped_stats.patch - outdated
* drop 702-phy_add_aneg_done_function.patch - upstream
* drop 840-rtc7301.patch - unused
* drop 841-rtc_pt7c4338.patch - upstream
* drop 921-use_preinit_as_init.patch - unused
* drop spio-gpio-old and gpio-mmc - unused

Signed-off-by: John Crispin <john@phrozen.org>
---
 .../generic/patches-4.4/280-rfkill-stubs.patch     | 79 ----------------------
 1 file changed, 79 deletions(-)
 delete mode 100644 target/linux/generic/patches-4.4/280-rfkill-stubs.patch

(limited to 'target/linux/generic/patches-4.4/280-rfkill-stubs.patch')

diff --git a/target/linux/generic/patches-4.4/280-rfkill-stubs.patch b/target/linux/generic/patches-4.4/280-rfkill-stubs.patch
deleted file mode 100644
index 96a98e219a..0000000000
--- a/target/linux/generic/patches-4.4/280-rfkill-stubs.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- a/net/rfkill/Kconfig
-+++ b/net/rfkill/Kconfig
-@@ -1,7 +1,11 @@
- #
- # RF switch subsystem configuration
- #
--menuconfig RFKILL
-+config RFKILL
-+	bool
-+	default y
-+
-+menuconfig RFKILL_FULL
- 	tristate "RF switch subsystem support"
- 	help
- 	  Say Y here if you want to have control over RF switches
-@@ -13,19 +17,19 @@ menuconfig RFKILL
- # LED trigger support
- config RFKILL_LEDS
- 	bool
--	depends on RFKILL
-+	depends on RFKILL_FULL
- 	depends on LEDS_TRIGGERS = y || RFKILL = LEDS_TRIGGERS
- 	default y
- 
- config RFKILL_INPUT
- 	bool "RF switch input support" if EXPERT
--	depends on RFKILL
-+	depends on RFKILL_FULL
- 	depends on INPUT = y || RFKILL = INPUT
- 	default y if !EXPERT
- 
- config RFKILL_REGULATOR
- 	tristate "Generic rfkill regulator driver"
--	depends on RFKILL || !RFKILL
-+	depends on RFKILL_FULL || !RFKILL_FULL
- 	depends on REGULATOR
- 	help
-           This options enable controlling radio transmitters connected to
-@@ -36,7 +40,7 @@ config RFKILL_REGULATOR
- 
- config RFKILL_GPIO
- 	tristate "GPIO RFKILL driver"
--	depends on RFKILL
-+	depends on RFKILL_FULL
- 	depends on GPIOLIB || COMPILE_TEST
- 	default n
- 	help
---- a/net/rfkill/Makefile
-+++ b/net/rfkill/Makefile
-@@ -4,6 +4,6 @@
- 
- rfkill-y			+= core.o
- rfkill-$(CONFIG_RFKILL_INPUT)	+= input.o
--obj-$(CONFIG_RFKILL)		+= rfkill.o
-+obj-$(CONFIG_RFKILL_FULL)	+= rfkill.o
- obj-$(CONFIG_RFKILL_REGULATOR)	+= rfkill-regulator.o
- obj-$(CONFIG_RFKILL_GPIO)	+= rfkill-gpio.o
---- a/net/Makefile
-+++ b/net/Makefile
-@@ -49,7 +49,7 @@ obj-$(CONFIG_MAC80211)		+= mac80211/
- obj-$(CONFIG_TIPC)		+= tipc/
- obj-$(CONFIG_NETLABEL)		+= netlabel/
- obj-$(CONFIG_IUCV)		+= iucv/
--obj-$(CONFIG_RFKILL)		+= rfkill/
-+obj-$(CONFIG_RFKILL_FULL)	+= rfkill/
- obj-$(CONFIG_NET_9P)		+= 9p/
- obj-$(CONFIG_CAIF)		+= caif/
- ifneq ($(CONFIG_DCB),)
---- a/include/linux/rfkill.h
-+++ b/include/linux/rfkill.h
-@@ -64,7 +64,7 @@ struct rfkill_ops {
- 	int	(*set_block)(void *data, bool blocked);
- };
- 
--#if defined(CONFIG_RFKILL) || defined(CONFIG_RFKILL_MODULE)
-+#if defined(CONFIG_RFKILL_FULL) || defined(CONFIG_RFKILL_FULL_MODULE)
- /**
-  * rfkill_alloc - allocate rfkill structure
-  * @name: name of the struct -- the string is not copied internally
-- 
cgit v1.2.3