From b2e63b8ea81fae72aef69649631cf491bac5306f Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Thu, 14 Mar 2013 14:45:56 +0000
Subject: kernel: add support for 3.9-rc2

Signed-off-by: Florian Fainelli <florian@openwrt.org>

SVN-Revision: 36008
---
 .../generic/patches-3.9/722-phy_mvswitch.patch     | 23 ++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 target/linux/generic/patches-3.9/722-phy_mvswitch.patch

(limited to 'target/linux/generic/patches-3.9/722-phy_mvswitch.patch')

diff --git a/target/linux/generic/patches-3.9/722-phy_mvswitch.patch b/target/linux/generic/patches-3.9/722-phy_mvswitch.patch
new file mode 100644
index 0000000000..d7c3d759a8
--- /dev/null
+++ b/target/linux/generic/patches-3.9/722-phy_mvswitch.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -127,6 +127,10 @@ config ADM6996_PHY
+ 	  Currently supports the ADM6996FC and ADM6996M switches.
+ 	  Support for FC is very limited.
+ 
++config MVSWITCH_PHY
++	tristate "Driver for Marvell 88E6060 switches"
++	select ETHERNET_PACKET_MANGLE
++
+ config FIXED_PHY
+ 	bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ 	depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_BCM63XX_PHY)	+= bcm63xx.o
+ obj-$(CONFIG_BCM87XX_PHY)	+= bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY)	+= icplus.o
+ obj-$(CONFIG_ADM6996_PHY)	+= adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY)	+= mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY)	+= realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY)	+= et1011c.o
+ obj-$(CONFIG_FIXED_PHY)		+= fixed.o
-- 
cgit v1.2.3